[Solved] significant performance issues after installation

Any issues with the XWAU or X-Wing Alliance? Please let us know here!
Post Reply

[Solved] significant performance issues after installation

joshtb86
Recruit
Posts: 7
Joined: Thu May 28, 2020 9:29 pm

Post by joshtb86 » Fri May 29, 2020 12:19 am

Hi everyone! hope that you can help me out here.

I installed the Steam version, and was using just the darksaber craft pack until i started to look around this site and saw the other stuff, so i uninstalled everything, deleted the folder, then installed these

XWAUCP 1.6 followed by

Effects by Blue Max's Version 1.1.3.1
Rebel Dynamic Cockpits Version 2.0
Tie Fighter Dynamic Cockpits Version 1.0
Super Backdrops Version 2.1
Crew Quarters Upgrade Version 1.0

my performance now is abysmal. it ranges anywhere from 20 - 80 fps, but in combat its in the 20s

i dont think hardware is the problem here - these are my specs

i7 6700k oc'd to 4.7 ghz
24 gb dd4 3444 ram
1080 oc'd
boot drive is nvme
game is ran off a 7200 rpm sata 3 hdd

im not sure why the performance has dropped so much

i did not enable anti aliasing in the installation for effects? i think it was
i otherwise basically used the default installation settings for each

what should the next step here be?

thanks in advance for all the help!
Last edited by Ace Antilles on Wed Sep 30, 2020 2:05 pm, edited 1 time in total.
Reason: Solved

Chri360936
Cadet 3rd Class
Posts: 28
Joined: Thu Jun 20, 2019 3:28 am

Post by Chri360936 » Fri May 29, 2020 1:39 am

Try changing your processaffinitycore to 0 in ddraw.cfg.

This may affect the in flight music though but your frame rate increases.

User avatar
blue_max
Lieutenant Commander
XWAU Member
Posts: 1368
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Fri May 29, 2020 5:03 pm


ltajax
Recruit
Posts: 4
Joined: Thu Aug 27, 2020 12:52 pm

Post by ltajax » Fri Aug 28, 2020 7:26 am

I'm having the same issues with my system. I installed the same mods yet I'm getting very low fps when encountering multiple ships at the same time. My experience is the same as OP's.

I have tried the recommended steps to rectify the issue but it has not resolved it.

My PC

Intel 6700k @4.2Ghz
Nvidia GTX 1080 8GB
32GB Ram at 3200Mhz
Game is installed on m.2 drive

User avatar
blue_max
Lieutenant Commander
XWAU Member
Posts: 1368
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Fri Aug 28, 2020 4:19 pm

ltajax wrote:
Fri Aug 28, 2020 7:26 am
I'm having the same issues with my system. I installed the same mods yet I'm getting very low fps when encountering multiple ships at the same time.
Sometimes I wonder what people are expecting. You didn't mention what you consider "low fps" to be; but getting 20-30fps when there are lots of ships on the screen is normal. If you installed some of the latest capital ships, like the ISD2, then that is to be expected since this game's 3D engine is still running on the CPU and those models have a lot of detail. If you can hit 60fps or above when there are no capital ships in sight, then your system is OK. You can also try installing Jeremy's ddraw to see what is the maximum possible performance.

ltajax
Recruit
Posts: 4
Joined: Thu Aug 27, 2020 12:52 pm

Post by ltajax » Fri Aug 28, 2020 10:50 pm

Just to clarify yes I think sub 30 fps is low relative to my system. So I reinstalled X-Wing Alliance and then installed a few mods at a time to see what was causing the issue for me.

I can run all the following while maintaining 60 FPS, I have not adjusted the frame-rate limit.

XWAUCP 1.6
XWAUCP 1.6 patch
All ships labeled 'New' in the downloads section
Rebel Dynamic Cockpits Version 2.0
Tie Fighter Dynamic Cockpits Version 1.0
Super Backdrops Version 2.1
Crew Quarters Upgrade Version 1.0

It appears Blue Max's Version 1.1.3.1 is the mod that decreases the FPS

When I install Effects by Blue Max's Version 1.1.3.1 with just XWAUCP 1.6, my frame rate drops down to the 30/20 fps with it dipping below 20 when the object density becomes too great. But without Blue Max's Version 1.1.3.1 it maintained 60fps.

It's a pity because its a really cool feature that completely changes to feel of the game.

I noticed both I and OP are both for the most part running the same rig, and having similar issues.

User avatar
Ace Antilles

Admiral (Moderator)
Posts: 4736
Joined: Sat Jan 22, 2000 12:01 am
Contact:

Post by Ace Antilles » Fri Aug 28, 2020 11:21 pm

You should be running Effects by Blue Max's Version 1.1.4 now.
Yes it will lower FPS in some areas but it adds a lot to the game too.
Why not try different configurations by not using all the options.

You have to remember that the original game has to have a hook to even let it run at 60fps so we've come a long way.
By adding the effects we have made the game look better but obviously there is some cost to that.
We are working on ways to improve things all the time but for right now if you want the highest FPS you will have to decide if you can live with the effects or not.
Personally for me I can't go back, especially the horrible old Hyperspace animation.
Chief XWAU Team annoying nitpicker.
Ace Antilles - The X-Wing Outpost
Image

User avatar
blue_max
Lieutenant Commander
XWAU Member
Posts: 1368
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Fri Aug 28, 2020 11:24 pm

Alright, fair enough. However, you're using an old version of the effects, so try installing 1.1.4 and the latest beta patch for it (it will fix some performance issues related to text rendering). I've got a laptop with an i7 and nVidia 1060 from 2 years ago and I can get 50-60fps at ~4K resolution and more than that if I lower the resolution (unless the screen is very busy). So, yes, you should be able to get more performance out of your system.

I think the biggest bottlenecks for performance are the desktop resolution (what's your resolution?) and the ProcessAffinityCore setting in DDraw.cfg (set it to 0).

Bear in mind, though, that your performance will drop anyway if you have lots of ships on the screen.

ltajax
Recruit
Posts: 4
Joined: Thu Aug 27, 2020 12:52 pm

Post by ltajax » Sat Aug 29, 2020 7:00 am

I did ensure the ProcessAffinityCore setting in DDraw.cfg was set to 0 as per previous recommendations, My desktop is 2560x1440, I tried running the game in various resolutions but found it did not change performance. I will try the latest version of your effects and see if that offers better results. IT may be your laptop i7 offers better single-core performance than my 5 years old i7.

ltajax
Recruit
Posts: 4
Joined: Thu Aug 27, 2020 12:52 pm

Post by ltajax » Sat Aug 29, 2020 8:00 am

So after updating and installing the beta version of Effects by Blue Max's I have seen a large increase in performance. I have been doing all my comparisons on mission 6 as it is where I noticed the dips. When I would arrive at the rebel hopsoital before if I looked in the direction of the ships and the station I would see my fps drop to 40, now it only drops to 70/80. When imperial forces would arrive the framerate previously went to 30 an less as more ships spawned, now when the imperials arrive my frame rate is now 60/70, the solution has effectivly doubled my frames. Performance does decrease when more ships arrive but not to the degree it was previously. Thank for helping with this.

Bunny Punch
Recruit
Posts: 5
Joined: Tue Sep 22, 2020 4:57 pm

Post by Bunny Punch » Fri Oct 02, 2020 4:54 pm

1st off, Big thanks from an OG XWing 93 player for all the work the devs have put into this!

Can I install Blue's beta effects pack over the latest official release or should I do a clean reinstall?

Thanks,
BP

User avatar
DarHan
Cadet 1st Class
Rebel Alliance
Posts: 245
Joined: Mon Dec 05, 2005 12:01 am
Contact:

Post by DarHan » Fri Oct 02, 2020 5:21 pm

You need to install the official release, then copy the beta over it.
“Red Four, nothing’s gone wrong yet.”
— Hobbie Klivian

Bunny Punch
Recruit
Posts: 5
Joined: Tue Sep 22, 2020 4:57 pm

Post by Bunny Punch » Mon Oct 05, 2020 5:20 pm

DarHan wrote:
Fri Oct 02, 2020 5:21 pm
You need to install the official release, then copy the beta over it.
Thank you! I also saw a performance increase with the beta. Many thanks to the devs!

Post Reply