Graphical Jitter/Flicker with Backgrounds and models

Any issues with the XWAU or X-Wing Alliance? Please let us know here!
Post Reply

Graphical Jitter/Flicker with Backgrounds and models

Basuru
Recruit
Posts: 6
Joined: Thu Aug 20, 2020 10:41 pm

Post by Basuru » Thu Aug 20, 2020 10:45 pm

Hi!

I'm loving the upgrade, but I'm getting some weird jitter/flicker with the backgrounds and sometime the models too. I've had a look for 'jitter' and 'flicker' but I can't find anything.

Anyone else have this? Anyone know what might be causing it?

(Win 10, 1080, i7 7700k, 32 Gb RAM)

Cheers!

Edit: When in third person, my ship is vibrating. Maybe the cause?

Edit 2: Things seem to jitter/flicker independently of the player ship.
Last edited by Basuru on Thu Aug 20, 2020 11:24 pm, edited 1 time in total.

User avatar
blue_max
Lieutenant Commander
XWAU Member
Posts: 1388
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Thu Aug 20, 2020 11:24 pm

Can you tell us what did you install? Does the jitter happen all the time or only in certain places?

Basuru
Recruit
Posts: 6
Joined: Thu Aug 20, 2020 10:41 pm

Post by Basuru » Thu Aug 20, 2020 11:28 pm

I installed the main pack, the effects, the backgrounds, the 'NEW' ships and the hooks. I think that's all.

There's no specific place. It can be every minute, or every few seconds. Makes aiming hard!

Edit: Tried a full reinstall twice too :(

Basuru
Recruit
Posts: 6
Joined: Thu Aug 20, 2020 10:41 pm

Post by Basuru » Fri Aug 21, 2020 1:02 am

No jitter when using vanilla, even just installing the standard upgrade pack alone, it causes the jitter.

User avatar
Ace Antilles

Admiral (Moderator)
Posts: 4793
Joined: Sat Jan 22, 2000 12:01 am
Contact:

Post by Ace Antilles » Fri Aug 21, 2020 1:40 am

Check all your in game hardware settings are turned on.
Things like Mip Mapping and the 3D Hardware etc
Chief XWAU Team annoying nitpicker.
Ace Antilles - The X-Wing Outpost
Image

Basuru
Recruit
Posts: 6
Joined: Thu Aug 20, 2020 10:41 pm

Post by Basuru » Fri Aug 21, 2020 2:11 am

Ace Antilles wrote:
Fri Aug 21, 2020 1:40 am
Check all your in game hardware settings are turned on.
Things like Mip Mapping and the 3D Hardware etc
Just went and checked - it's all on.

I've also installed the GOG version just now, same issue. :(

User avatar
blue_max
Lieutenant Commander
XWAU Member
Posts: 1388
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Fri Aug 21, 2020 6:43 am

Are you running the game with hardware acceleration? A lot of computers come with integrated graphics (made by Intel) and a real GPU (like nVidia or AMD). Applications tend to run on the integrated graphics by default and thus get lower performance. Make sure your game is running with your nVidia or AMD card (you can see which card the game is using in XWA's menu). Can you post a video of the problem?

Basuru
Recruit
Posts: 6
Joined: Thu Aug 20, 2020 10:41 pm

Post by Basuru » Fri Aug 21, 2020 8:45 am

Alright, so I've got a video of the background flicker here, along with my video settings. When I turn back towards the Azzameen home, you can see it quite clearly.:

https://streamable.com/zujins

This one shows more jitter/flicker:

https://streamable.com/nfiv0n

I appreciate you guys taking the time!

User avatar
blue_max
Lieutenant Commander
XWAU Member
Posts: 1388
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Fri Aug 21, 2020 9:12 pm

Alright, there's several things in the second video:

1. The cockpit itself is jittering a litte bit. This might be because of the inertia effect. If you want to test that, you can press Ctrl+Alt+I to toggle the effect on and off. Or you can just disable it in the CockpitLook.cfg (look for the "inertia" settings).
2. There are some textures in the cockpit near the edges of the screen that "jump" a little bit. Some cockpits do that, and I think it's "normal" in the sense that the engine does that. We don't have a fix for that problem, but we're aware of it.
3. There's a slight "jump" in the video that can be noticed because the background starfield moves a little too fast between frames. I haven't noticed that before and I'm probably only noticing it now because I'm paying attention. The background is rendered as a big cube, so it might be "normal" (a limitation of an old engine).

Your video settings look fine to me. I think at the moment the only thing you can do is disable cockpit inertia to prevent the cockpit from shaking to see if that helps.

Basuru
Recruit
Posts: 6
Joined: Thu Aug 20, 2020 10:41 pm

Post by Basuru » Sat Aug 22, 2020 8:28 pm

Hey - Thanks so much for getting back.

I disabled cockpit inertia, but I'm still getting the jitters. Not really sure what to do.

Also - please don't take this as me criticising the mod - this mod is incredible and I'm grateful for it, I'm just trying to see if I can iron out some kinks on my end.

woodat
Recruit
Posts: 1
Joined: Sun Sep 06, 2020 7:15 pm

Post by woodat » Sun Sep 06, 2020 7:24 pm

Just came on these forums to look if anyone else was experiencing this. Am having the same issue. Of note, am using a Radeon RX5700 (so isn't just nvidia, if that helps in any small way)

User avatar
blue_max
Lieutenant Commander
XWAU Member
Posts: 1388
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Tue Sep 08, 2020 9:46 pm

Well, like I said, you can expect a little bit of jittering in the background and the cockpits. I'm not sure why that's happening -- although, if forced to guess, I'd say it's because the game uses fixed-point precision? In other words, this might be a limitation of the game engine.

Have you guys tried checking what happens with Jeremy's ddraw?

Luke_Skywalker
Cadet 1st Class
Posts: 117
Joined: Fri Mar 11, 2005 12:01 am

Post by Luke_Skywalker » Tue Sep 08, 2020 11:54 pm

Does the same thing with Jeremy's.
When 900 years old you reach, look as good, you will not. Hmm?" -Yoda

User avatar
blue_max
Lieutenant Commander
XWAU Member
Posts: 1388
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Wed Sep 09, 2020 12:05 am

Luke_Skywalker wrote:
Tue Sep 08, 2020 11:54 pm
Does the same thing with Jeremy's.
Then it's probably a limitation of the game engine, sorry. Thanks for checking, though.

Luke_Skywalker
Cadet 1st Class
Posts: 117
Joined: Fri Mar 11, 2005 12:01 am

Post by Luke_Skywalker » Fri Sep 11, 2020 5:57 am

It's probably more pronounced with the new backgrounds. The originals were pretty sparse so nobody really noticed anything.
When 900 years old you reach, look as good, you will not. Hmm?" -Yoda

Post Reply