[Bug] TieDynamiccockpits????

Any issues with the XWAU or X-Wing Alliance? Please let us know here!
Post Reply

[Bug] TieDynamiccockpits????

baggy101
Cadet 2nd Class
Posts: 59
Joined: Mon Feb 02, 2015 9:32 am

Post by baggy101 » Mon Aug 24, 2020 7:11 pm

Hi, Ive got all the dynamic cockpits working except the Tiefighter? any Ideas?

User avatar
blue_max
Lieutenant Commander
XWAU Member
Posts: 1388
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Mon Aug 24, 2020 7:14 pm

Check if your DynamicCockpit directory has a TieFighteCockpit.dc file. If it's there, please post it here so that we can check it.

baggy101
Cadet 2nd Class
Posts: 59
Joined: Mon Feb 02, 2015 9:32 am

Post by baggy101 » Mon Aug 24, 2020 7:34 pm

; Available Source Names (use these labels with the uv_coords command):
;01 TARGETING_COMPUTER_SRC
;02 LEFT_TEXT_BOX_SRC
;03 RIGHT_TEXT_BOX_SRC
;04 LEFT_SENSOR_SRC
;05 RIGHT_SENSOR_SRC
;06 SHIELDS_SRC
;07 DUAL_LASERS_L_SRC
;08 DUAL_LASERS_R_SRC

;09 MISSILES_SRC
;10 SPEED_THROTTLE_SRC
;11 BEAM_LEVEL_SRC
;12 NAME_TIME_SRC
;13 NUM_SHIPS_SRC
;14 LASER_RECHARGE_SRC
;15 SHIELD_RECHARGE_SRC
;16 ENGINE_POWER_SRC
;17 BEAM_RECHARGE_SRC

; Available HUD regions (use these labels with the erase_region command):
;01 TARGET_AND_LASERS_REGION
;02 LEFT_TEXT_BOX_REGION
;03 RIGHT_TEXT_BOX_REGION
;04 LEFT_SENSOR_REGION
;05 RIGHT_SENSOR_REGION
;06 SHIELDS_REGION
;07 TOP_LEFT_REGION
;08 TOP_RIGHT_REGION
;11 BEAM_REGION



;1
[TieFighterCockpit.opt,Tex00050]
cover_texture = DynamicCockpit\TieFighter-targeting-cover.png
cover_texture_size = 512,256
uv_coords = TARGETING_COMPUTER_SRC, 40,216, 472,70; 0x0
erase_region = TARGET_AND_LASERS_REGION

;2
[TieFighterCockpit.opt,Tex00067]
cover_texture_size = 256,256
uv_coords = LEFT_TEXT_BOX_SRC, 10,256, 246,0; 0x0
erase_region = LEFT_TEXT_BOX_REGION

;3
[TieFighterCockpit.opt,Tex00060]
cover_texture_size = 256,256
uv_coords = RIGHT_TEXT_BOX_SRC, 10,256, 246,0; 0x0
erase_region = RIGHT_TEXT_BOX_REGION

;4
[TieFighterCockpit.opt,Tex00066]
cover_texture = DynamicCockpit\TieFighter-leftsensors-cover.png
cover_texture_size = 256,256
uv_coords = LEFT_SENSOR_SRC, 0,256, 256,0; 0x0
erase_region = LEFT_SENSOR_REGION

;5
[TieFighterCockpit.opt,Tex00064]
cover_texture = DynamicCockpit\TieFighter-rightsensors-cover.png
cover_texture_size = 256,256
uv_coords = RIGHT_SENSOR_SRC, 0,256, 256,0; 0x0
erase_region = RIGHT_SENSOR_REGION

;6
[TieFighterCockpit.opt,Tex00065]
cover_texture = DynamicCockpit\TieFighter-shield-cover.png
cover_texture_size = 128,128
uv_coords = SHIELDS_SRC, 0,128, 128,0; 0x0
erase_region = SHIELDS_REGION

;7
[TieFighterCockpit.opt,Tex00075]
cover_texture = DynamicCockpit\TieFighter-laser-cover.png
cover_texture_size = 256,32
uv_coords = DUAL_LASERS_L_SRC, 0,32, 256,0; 0x0

;8
[TieFighterCockpit.opt,Tex00074]
cover_texture = DynamicCockpit\TieFighter-laser-cover.png
cover_texture_size = 256,32
uv_coords = DUAL_LASERS_R_SRC, 0,32, 256,0; 0x0

;9
[TieFighterCockpit.opt,Tex00053]
cover_texture = DynamicCockpit\TieFighter-time-cover.png
cover_texture_size = 64,32
uv_coords = MISSILES_SRC, 10,32, 54,0; 0x0

;10
[TieFighterCockpit.opt,Tex00056]
cover_texture = DynamicCockpit\TieFighter-time-cover.png
cover_texture_size = 64,32
uv_coords = SPEED_THROTTLE_SRC, 5,32, 59,0; 0x0

;11
[TieFighterCockpit.opt,Tex00062]
cover_texture = DynamicCockpit\TieFighter-beam-cover.png
cover_texture_size = 128,128
uv_coords = BEAM_LEVEL_SRC, 0,128, 128,0; 0x0
erase_region = BEAM_REGION

;12
[TieFighterCockpit.opt,Tex00076]
cover_texture = DynamicCockpit\TieFighter-time-cover.png
cover_texture_size = 64,32
uv_coords = NAME_TIME_SRC, 5,32, 59,0; 0x0
erase_region = TOP_RIGHT_REGION

;13
[TieFighterCockpit.opt,Tex00054]
cover_texture = DynamicCockpit\TieFighter-time-cover.png
cover_texture_size = 64,32
uv_coords = NUM_SHIPS_SRC, 10,32, 54,0; 0x0
erase_region = TOP_LEFT_REGION

;14
[TieFighterCockpit.opt,Tex00057]
cover_texture = DynamicCockpit\TieFighter-laserlevel-cover.png
cover_texture_size = 128,512
uv_coords = LASER_RECHARGE_SRC, -30,512, 158,0; 0x0

;15
[TieFighterCockpit.opt,Tex00069]
cover_texture = DynamicCockpit\TieFighter-shieldlevel-cover.png
cover_texture_size = 64,128
uv_coords = SHIELD_RECHARGE_SRC, -64,128, 128,0; 0x0

;16
[TieFighterCockpit.opt,Tex00059]
cover_texture = DynamicCockpit\TieFighter-enginelevel-cover.png
cover_texture_size = 128,512
uv_coords = ENGINE_POWER_SRC, -30,512, 158,0; 0x0

;17
[TieFighterCockpit.opt,Tex00068]
cover_texture = DynamicCockpit\TieFighter-beamlevel-cover.png
cover_texture_size = 64,128
uv_coords = BEAM_RECHARGE_SRC, -64,128, 128,0; 0x0

;FIELD OF VIEW
xwahacker_fov = 88.0
xwahacker_large_fov = 95.5

baggy101
Cadet 2nd Class
Posts: 59
Joined: Mon Feb 02, 2015 9:32 am

Post by baggy101 » Mon Aug 24, 2020 7:48 pm

It looks like the correct Cockpit opt is loaded but the FOV is too close, the instruments are blank and i still have a full HUD

User avatar
blue_max
Lieutenant Commander
XWAU Member
Posts: 1388
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Mon Aug 24, 2020 8:14 pm

baggy101 wrote:
Mon Aug 24, 2020 7:48 pm
It looks like the correct Cockpit opt is loaded but the FOV is too close, the instruments are blank and i still have a full HUD
What version of ddraw/beta patch are you running? Older versions are case-sensitive, so "TIEFIghterCockpit.OPT" is different from "TieFIghterCockpit.opt".

Check the name of the OPT, make sure it's "TieFighterCockpit.opt" (I would just rename it like that, just in case).

baggy101
Cadet 2nd Class
Posts: 59
Joined: Mon Feb 02, 2015 9:32 am

Post by baggy101 » Mon Aug 24, 2020 9:27 pm

So I've double checked that the TieFighterCockpit.opt is correctly named, which it is. However I checked the cockpit with mxvted and found the tie fighter cockpit assigned with tiefightermg. I've changed it to tiefighter but still no luck.

baggy101
Cadet 2nd Class
Posts: 59
Joined: Mon Feb 02, 2015 9:32 am

Post by baggy101 » Mon Aug 24, 2020 9:44 pm

Tiefightermg is odd as I’ve no installed it yet either oh and now have no hud.

User avatar
blue_max
Lieutenant Commander
XWAU Member
Posts: 1388
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Mon Aug 24, 2020 10:05 pm

Why don't you try a clean install? You could try re-installing the TIE Dynamic cockpits first, to see if that fixes the problem, and then do a fresh install of XWA followed by XWAUP 1.6 and then Effects 1.1.4 and the Dynamic Cockpits.

baggy101
Cadet 2nd Class
Posts: 59
Joined: Mon Feb 02, 2015 9:32 am

Post by baggy101 » Mon Aug 24, 2020 10:19 pm

This a was a fresh install, I will give it go

baggy101
Cadet 2nd Class
Posts: 59
Joined: Mon Feb 02, 2015 9:32 am

Post by baggy101 » Mon Aug 24, 2020 11:16 pm

sorted, thanks blue_max. I'm guessing its something to with the TIE fighter installer using tiefightermg for the standard tie cockpit maybe? just re re re installed the dynamic tie and it worked. thanks

User avatar
blue_max
Lieutenant Commander
XWAU Member
Posts: 1388
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Tue Aug 25, 2020 12:12 am

No problem, glad it worked for you!

User avatar
heloguy
Cadet 3rd Class
Posts: 41
Joined: Wed Nov 28, 2007 12:01 am

Post by heloguy » Wed Aug 26, 2020 3:10 pm

I just had this same issue, and used mxvted to change the name from TieFighterMG to just TieFighter. That fixed things for me.

@bagey, not sure if you were doing something similar to me, but I'm installing Blue Max's cockpits and effects over a TFTC v1.0 install. The standard TIE Fighter was the only dynamic cockpit that wasn't working, all of the others were working as advertised.

Post Reply