Laser colours

Any issues with the XWAU or X-Wing Alliance? Please let us know here!
Post Reply

Laser colours

Zel_451
Recruit
Posts: 2
Joined: Sat Aug 15, 2020 1:34 pm

Post by Zel_451 » Thu Sep 17, 2020 3:34 pm

Hey there XWA Team. Unfortunatly I lost my old login info from way back in 2001. Haven't checked on the project for a very long time and am amazed by all the cool new things you have created. Love the interactive cockpits and gorgous new backdrops.

One thing I noticed and am not certain wheter it is a bug or a feature are the different laser colours some ships use. I especially noticed that the lancer frigates in one of the early family missions shoots yellow coloured blaster bolts while beeing an Imperial ship.

Is that as it should be, or did I do something wrong when installing all the new patches and hooks and addons? Maybe I did not install everything in order?

User avatar
blue_max
Lieutenant Commander
XWAU Member
Posts: 1368
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Thu Sep 17, 2020 4:35 pm

I am not sure about the Lancer Frigate, but I believe the coloring of the lasers is intentional. I think there's a section in the FlightModels/LancerFrigate.ini file that configures the color, but I'm not sure how that works. Other imperial craft should still fire green lasers, so if you see *every craft* firing yellow, then there might be a bug.

User avatar
DarHan
Cadet 1st Class
Rebel Alliance
Posts: 245
Joined: Mon Dec 05, 2005 12:01 am
Contact:

Post by DarHan » Thu Sep 17, 2020 5:00 pm

The Lancer frigate firing yellow lasers is correct. See this post.
“Red Four, nothing’s gone wrong yet.”
— Hobbie Klivian

Zel_451
Recruit
Posts: 2
Joined: Sat Aug 15, 2020 1:34 pm

Post by Zel_451 » Thu Sep 17, 2020 5:38 pm

Thank you.

Post Reply