[HELP/BUG] Opt makes game ctd

Any issues with the XWAU or X-Wing Alliance? Please let us know here!
Post Reply

[HELP/BUG] Opt makes game ctd

baggy101
Cadet 2nd Class
Posts: 56
Joined: Mon Feb 02, 2015 9:32 am

Post by baggy101 » Thu Sep 17, 2020 9:18 pm

Hi, I’m messing about with the old houndstooth opt but it seems to make the game ctd after a while in the mission. Any ideas?

Relocated to Bug Reports and Help Requests section
- Driftwood

User avatar
Ace Antilles

Admiral (Moderator)
Posts: 4736
Joined: Sat Jan 22, 2000 12:01 am
Contact:

Post by Ace Antilles » Sun Sep 20, 2020 2:57 am

baggy101 wrote:
Thu Sep 17, 2020 9:18 pm
Hi, I’m messing about with the old houndstooth opt but it seems to make the game ctd after a while in the mission. Any ideas?

Relocated to Bug Reports and Help Requests section
- Driftwood
So it doesn't crash at first?
It's an old opt it could be anything. Are you sure it's an XWA one and not a XVT Opt?
Best is to submit a crash log from the Event Viewer.
Chief XWAU Team annoying nitpicker.
Ace Antilles - The X-Wing Outpost
Image

baggy101
Cadet 2nd Class
Posts: 56
Joined: Mon Feb 02, 2015 9:32 am

Post by baggy101 » Sun Sep 20, 2020 6:37 pm

Yeah it loads fine in the library, it’ll load in game for a period of between 0 seconds and 2mins then ctd or freeze. I’m pretty sure it’s the xwa version. I’m having the same problem with darksabers moldy crow and the ig-2000. I’ll have a look for an event log and post it if I can find it.

baggy101
Cadet 2nd Class
Posts: 56
Joined: Mon Feb 02, 2015 9:32 am

Post by baggy101 » Sun Sep 20, 2020 10:14 pm

- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
<Provider Name="Application Error" />
<EventID Qualifiers="0">1000</EventID>
<Level>2</Level>
<Task>100</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2020-09-19T17:41:35.517004900Z" />
<EventRecordID>21239</EventRecordID>
<Channel>Application</Channel>
<Computer>DESKTOP-9S7M8IH</Computer>
<Security />
</System>
- <EventData>
<Data>XWingAlliance.exe</Data>
<Data>2.0.0.2</Data>
<Data>3765a9b7</Data>
<Data>XWingAlliance.exe</Data>
<Data>2.0.0.2</Data>
<Data>3765a9b7</Data>
<Data>c0000094</Data>
<Data>000d8e10</Data>
<Data>708</Data>
<Data>01d68eaa56b6c9d0</Data>
<Data>D:\Steam\steamapps\common\Star Wars X-Wing Alliance\XWingAlliance.exe</Data>
<Data>D:\Steam\steamapps\common\Star Wars X-Wing Alliance\XWingAlliance.exe</Data>
<Data>e52b3272-8c5b-4d97-8fda-328f64738958</Data>
<Data />
<Data />
</EventData>
</Event>

baggy101
Cadet 2nd Class
Posts: 56
Joined: Mon Feb 02, 2015 9:32 am

Post by baggy101 » Mon Sep 21, 2020 2:57 pm

Log Name: Application
Source: Windows Error Reporting
Date: 21/09/2020 15:52:46
Event ID: 1001
Task Category: None
Level: Information
Keywords: Classic
User: N/A
Computer: DESKTOP-9S7M8IH
Description:
Fault bucket 810596720, type 1
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: XwingAlliance.exe
P2: 2.0.0.2
P3: 3765a9b7
P4: XwingAlliance.exe
P5: 2.0.0.2
P6: 3765a9b7
P7: c0000094
P8: 000d8e10
P9:
P10:

Attached files:
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER2D4B.tmp.dmp
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER302A.tmp.WERInternalMetadata.xml
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER3079.tmp.xml
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER3096.tmp.csv
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER30E6.tmp.txt

These files may be available here:
\\?\C:\ProgramData\Microsoft\Windows\WER\ReportArchive\AppCrash_XwingAlliance.ex_ef553f0a1ca18b3c4a9dffe541cbd831aef7_35d6de86_fe03e493-0a76-4352-b064-434e3578e013

Analysis symbol:
Rechecking for solution: 0
Report Id: 369c9fa2-4d7e-4cd3-b969-09a85bdaa5e4
Report Status: 268435456
Hashed bucket: ea3f8782aac86d8212c6e7e744fb7030
Cab Guid: 0
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Windows Error Reporting" />
<EventID Qualifiers="0">1001</EventID>
<Level>4</Level>
<Task>0</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2020-09-21T14:52:46.375219300Z" />
<EventRecordID>21414</EventRecordID>
<Channel>Application</Channel>
<Computer>DESKTOP-9S7M8IH</Computer>
<Security />
</System>
<EventData>
<Data>810596720</Data>
<Data>1</Data>
<Data>APPCRASH</Data>
<Data>Not available</Data>
<Data>0</Data>
<Data>XwingAlliance.exe</Data>
<Data>2.0.0.2</Data>
<Data>3765a9b7</Data>
<Data>XwingAlliance.exe</Data>
<Data>2.0.0.2</Data>
<Data>3765a9b7</Data>
<Data>c0000094</Data>
<Data>000d8e10</Data>
<Data>
</Data>
<Data>
</Data>
<Data>
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER2D4B.tmp.dmp
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER302A.tmp.WERInternalMetadata.xml
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER3079.tmp.xml
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER3096.tmp.csv
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER30E6.tmp.txt</Data>
<Data>\\?\C:\ProgramData\Microsoft\Windows\WER\ReportArchive\AppCrash_XwingAlliance.ex_ef553f0a1ca18b3c4a9dffe541cbd831aef7_35d6de86_fe03e493-0a76-4352-b064-434e3578e013</Data>
<Data>
</Data>
<Data>0</Data>
<Data>369c9fa2-4d7e-4cd3-b969-09a85bdaa5e4</Data>
<Data>268435456</Data>
<Data>ea3f8782aac86d8212c6e7e744fb7030</Data>
<Data>0</Data>
</EventData>
</Event>

baggy101
Cadet 2nd Class
Posts: 56
Joined: Mon Feb 02, 2015 9:32 am

Post by baggy101 » Tue Sep 22, 2020 11:51 am

Problem solved, it’s something to do with the shield discharge or promo points!

Cpt. Spaulding
Cadet 3rd Class
Posts: 32
Joined: Sat Dec 16, 2017 2:30 pm

Post by Cpt. Spaulding » Tue Sep 22, 2020 1:46 pm

I have the same problem for a mission, which i first thought was resulting from not correctly assigned opts. But i assigned them correctly now (in Allied), and i can play the mission for around 55 minutes and then it is also crashing to desktop...
How can i create an error log like baggy101 did? will this help or what could be other resaons for the game to crash in between a running mission?

User avatar
Forceflow

Fleet Admiral (Administrator)
Posts: 6050
Joined: Wed Oct 20, 1999 11:01 pm
Contact:

Post by Forceflow » Tue Sep 22, 2020 2:13 pm

You can find a small guide on how to access the windows even viewer here:
howtogeek.com
Posting the crash log is a good idea for sure!
baggy101 wrote:
Tue Sep 22, 2020 11:51 am
Problem solved, it’s something to do with the shield discharge or promo points!
Could you elaborate on how exactly the issue was fixed? This might help others to also fix the issue on their own.
Murphy was an optimist! I am a pessimist!
And always remember that a smile is cheaper than a bullet! (District 9)
Webmaster of the X-Wing Alliance Upgrade Project

baggy101
Cadet 2nd Class
Posts: 56
Joined: Mon Feb 02, 2015 9:32 am

Post by baggy101 » Tue Sep 22, 2020 3:23 pm

I’m not 100% sure, but I was looking somewhere in the forum and I found an old post with a simular problem to mine, I’ll try to post it. Either way I remember seeing mxvted release notes about the shield discharge Rate being swapped for promo points as it was kind of an unknown. Any way the post said that the game stopped working mid game and he’s narrowed the fault down to the fact that the shield discharge for the ship was set at 0, so changed the promo points to 4 and all seems well.

Post Reply