[Solved] Hangar Stutter - Effects from Blue Max

Any issues with the XWAU or X-Wing Alliance? Please let us know here!
Post Reply

[Solved] Hangar Stutter - Effects from Blue Max

wbrooks003
Recruit
Posts: 8
Joined: Fri Sep 18, 2020 6:37 pm

Post by wbrooks003 » Sun Sep 20, 2020 3:34 pm

Hello -

I have installed the latest Effects from Blue Max and am receiving the hangar stutter on the animation coming out of the hangar where my ship freezes but the other activities in the hanger seem to be moving appropriately.

I had read in a different post related to the Effects from Blue Max that this is fairly common. I tried playing around with the vsync hangar options in the ddraw file, but that did not make a difference whether it was on or off. Not a huge deal as it does not affect playability and the overall effects in this patch are awesome, but curious if there are other workarounds for the hangar matter.

I did notice that disabling the hook_time.dll fixed the issued, but then obviously you are capped back to 30 FPS in-flight as well. Are there any other solutions that were successful in addressing this?

Thanks and appreciate any suggestions.
Last edited by Ace Antilles on Tue Sep 29, 2020 8:10 pm, edited 1 time in total.
Reason: Solved

User avatar
blue_max
Lieutenant Commander
XWAU Member
Posts: 1388
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Sun Sep 20, 2020 6:14 pm

Have you tried setting your monitor refresh rate to 60Hz? Some people experience this problem if their refresh rates are above that value.

wbrooks003
Recruit
Posts: 8
Joined: Fri Sep 18, 2020 6:37 pm

Post by wbrooks003 » Sun Sep 20, 2020 8:26 pm

Thank you. That does help.

User avatar
JeremyaFr
Commander
XWAU Member
Posts: 2661
Joined: Mon Jan 18, 2010 5:52 pm
Contact:

Post by JeremyaFr » Mon Sep 21, 2020 4:23 pm

Hello,
Since it may cause issues, should I limit the FPS to 60 in hangar in the time hook?

User avatar
Ace Antilles

Admiral (Moderator)
Posts: 4793
Joined: Sat Jan 22, 2000 12:01 am
Contact:

Post by Ace Antilles » Fri Sep 25, 2020 9:57 pm

blue_max wrote:
Sun Sep 20, 2020 6:14 pm
Have you tried setting your monitor refresh rate to 60Hz? Some people experience this problem if their refresh rates are above that value.
JeremyaFr wrote:
Mon Sep 21, 2020 4:23 pm
Hello,
Since it may cause issues, should I limit the FPS to 60 in hangar in the time hook?
This issue does seem to pop up a lot. So if that fixes it without any Effects installs that could be a good idea.
Chief XWAU Team annoying nitpicker.
Ace Antilles - The X-Wing Outpost
Image

JohnMidnight
Recruit
Posts: 4
Joined: Sun Oct 23, 2011 3:02 am

Post by JohnMidnight » Sun Sep 27, 2020 1:40 am

In the DDRAW.cfg turn also on the VSYNC in there as well, not just the hangar one that was already on. THAT fixed my issue. I do not know if that's a overall fix, but we'll see.

https://i.imgur.com/IuKMooS.png

(I am running everything that's available on the XWA Download page :D )

User avatar
JeremyaFr
Commander
XWAU Member
Posts: 2661
Joined: Mon Jan 18, 2010 5:52 pm
Contact:

Post by JeremyaFr » Sun Sep 27, 2020 12:33 pm

UPDATE
Ace Antilles wrote:
Fri Sep 25, 2020 9:57 pm
This issue does seem to pop up a lot. So if that fixes it without any Effects installs that could be a good idea.
Done.

I've updated the time hook to limit fps to 60 in hangar.

Post Reply