XWA Custom & Widescreen Resolutions

Any issues with the XWAU or X-Wing Alliance? Please let us know here!

Re: XWA Custom & Widescreen Resolutions

Voyager
Cadet 4th Class
Posts: 20
Joined: Sun May 13, 2007 11:01 pm

Post by Voyager » Wed Jul 15, 2020 2:25 am

Ace Antilles wrote:
Wed Jul 15, 2020 12:50 am
Voyager wrote:
Wed Jul 15, 2020 12:45 am
Minor suggestion: For simplicity, when setting the resolutions in the installer, could the \Star Wars - X-Wing Alliance\DDRaw.cfg PreserveAspectRatio value be set to '1' by default?

The default install appears to set it to '0', which, if you've got a multi-monitor setup, ends up, rather spectacularly, distorting the view, until you figure out the right flag to change.

thank you,

Harry Voyager
There's an option in the latest Effects from Blue Max to change the Aspect Ratio
Ah cool. Had not gotten that far in the install stack yet. Was currently installing the new aircraft first. (Though my end goal is VR, so this is more an interim step while I get everything else working.)

Cpt. Spaulding
Cadet 3rd Class
Posts: 32
Joined: Sat Dec 16, 2017 2:30 pm

Post by Cpt. Spaulding » Sun Sep 13, 2020 9:04 pm

Hi all there, I'm using a new pc to run XWA:

My PC-Setup:
MSI B450M Pro-VDH MAX Mainboard
Ryzen 3 3100
Radeon RX 5500XT
16 GB RAM
Corsair MP510 960 GB SSD

I'm using it my TV (LG B7D) as screen.
How can i change game resolution to my TV 3840x2160 resolution?
First of all: XWA Hacker is not working for me (any solution about that? also admin mode does not help).
In the hook_resolution.cfg i typed i the following but it doesnt't change anything in game:

Code: Select all

; Auto set the game resolution
; 1 to enable the feature
; 0 to disable the feature
IsAutoResolutionEnabled = 0

; Define the resolution width
; When set to 0, the screen width is used
ResolutionWidth = 3840

; Define the resolution height
; When set to 0, the screen height is used
ResolutionHeight = 2160
Can anyone help?
Thx in advance. :)

User avatar
JeremyaFr
Commander
XWAU Member
Posts: 2628
Joined: Mon Jan 18, 2010 5:52 pm
Contact:

Post by JeremyaFr » Mon Sep 14, 2020 3:28 pm

Hello,
You need to set "IsAutoResolutionEnabled" to 1.

Cpt. Spaulding
Cadet 3rd Class
Posts: 32
Joined: Sat Dec 16, 2017 2:30 pm

Post by Cpt. Spaulding » Mon Sep 14, 2020 6:44 pm

Thank you, but i did that and the max resolution to choose in game is again only 1920 x 1080...

https://imgur.com/a/GiYJZZA

Code: Select all

; Auto set the game resolution
; 1 to enable the feature
; 0 to disable the feature
IsAutoResolutionEnabled = 1

; Define the resolution width
; When set to 0, the screen width is used
ResolutionWidth = 3840

; Define the resolution height
; When set to 0, the screen height is used
ResolutionHeight = 2160

User avatar
DarHan
Cadet 1st Class
Rebel Alliance
Posts: 245
Joined: Mon Dec 05, 2005 12:01 am
Contact:

Post by DarHan » Mon Sep 14, 2020 7:04 pm

Have you tested actually flying a mission? Due to the way the hook works, the resolution displayed in the options and the resolution actually used by the game might be different.

(For example, on my computer, I used XwaHacker so the options read as “800×500” but the game actually runs at my screen’s native resolution, which is 1680×1050.)
“Red Four, nothing’s gone wrong yet.”
— Hobbie Klivian

User avatar
JeremyaFr
Commander
XWAU Member
Posts: 2628
Joined: Mon Jan 18, 2010 5:52 pm
Contact:

Post by JeremyaFr » Mon Sep 14, 2020 7:08 pm

Cpt. Spaulding wrote:
Sun Sep 13, 2020 9:04 pm
In the hook_resolution.cfg i typed i the following but it doesnt't change anything in game:
Hello,
cfg files were the old method to configure the hooks. Now the settings are in the "hooks.ini" file.

Under the "[hook_resolution]" section of "hooks.ini", there are the settings for the resolution hook.

As DarHan wrote, the game will always use the screen’s native resolution.

Cpt. Spaulding
Cadet 3rd Class
Posts: 32
Joined: Sat Dec 16, 2017 2:30 pm

Post by Cpt. Spaulding » Mon Sep 14, 2020 7:13 pm

Thx Jeremy, that did the trick! Changing it in the hooks.ini worked perfectly fine! :)

Thx to DarHan too.

Post Reply