X-Wing Alliance VR mod

Here you can find help for how to best run and setup your XWA VR experience.
Post Reply

Re: X-Wing Alliance VR mod

User avatar
blue_max
Lieutenant Commander
XWAU Member
Posts: 1387
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Thu Jul 30, 2020 7:32 pm

Head tracking hasn't been enabled in the hangar yet, but it should work while flying.

EDIT: Please download the latest beta from July 31. This version has head tracking enabled while in the hangar.

Impi
Recruit
Posts: 2
Joined: Sun Aug 02, 2020 10:47 am

Post by Impi » Sun Aug 02, 2020 10:51 am

isometricbacon wrote:
Sun Jul 12, 2020 10:35 am
A couple of questions:
Any good way to diagnose potential faults further? The usual Steam Performance Profiler doesn't seem to pick up the game when it's running in VR (though it shows Alliance.exe and the resolution seems to affect it). It stays at 2 ms or so, even though it shows XWA is active.
For me it was Active Cockpit. Open Active_Cockpit.cfg and set active_cockpit_enabled to 0. I think the head tracking is just conflicting with the mouse. When I deactivated this I had no jitters anymore.

User avatar
blue_max
Lieutenant Commander
XWAU Member
Posts: 1387
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Sun Aug 02, 2020 2:41 pm

You should not use the mouse and head tracking at the same time, yes they will conflict with each other. The Active Cockpit in VR is meant to be used with head tracking. You point at things with your head

Impi
Recruit
Posts: 2
Joined: Sun Aug 02, 2020 10:47 am

Post by Impi » Sun Aug 02, 2020 3:05 pm

Still, for some reason disabling Active Cockpit made the game playable for me. :-)

User avatar
blue_max
Lieutenant Commander
XWAU Member
Posts: 1387
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Fri Aug 07, 2020 12:46 am

Thanks for reporting this, Impi: I've added your feedback to the Troubleshooting thread.

User avatar
Driftwood

Admiral (Moderator)
Posts: 2079
Joined: Wed Oct 22, 2003 11:01 pm
Contact:

Post by Driftwood » Fri Aug 07, 2020 7:06 pm

Did you also fix the game not releasing track IR (or vice versa) on exit (this requiring relaunch and exit) bug?

User avatar
blue_max
Lieutenant Commander
XWAU Member
Posts: 1387
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Fri Aug 07, 2020 7:09 pm

Driftwood wrote:
Fri Aug 07, 2020 7:06 pm
Did you also fix the game not releasing track IR (or vice versa) on exit (this requiring relaunch and exit) bug?
No, I have no idea what's going on there. I'm calling the functions to shut down TrackIR, so I'm not sure what I'm missing. Further, this area hasn't been touched in several months. Did this work before and just started acting weird recently?

User avatar
Driftwood

Admiral (Moderator)
Posts: 2079
Joined: Wed Oct 22, 2003 11:01 pm
Contact:

Post by Driftwood » Fri Aug 07, 2020 10:03 pm

Yeah, it worked fine and then one of the latest updates it started having issues. Ual is having the same problem.

I'm not sure what's changed or what version number prior to this didn't have the issue since I was a couple versions behind at that point of update and I do not recall which one I upgraded from.

P-Rock
Recruit
Posts: 5
Joined: Sun Aug 09, 2020 12:27 am

Post by P-Rock » Sun Aug 09, 2020 5:04 pm

I installed the VR mod yesterday, and so far I've had decent luck getting the game to be playable on my 7700k/1080Ti. Props to Bluemax! I do have a few issues though:
  • This has been noted a many times elsewhere, but performance is kind of all over the map. On the very first tutorial mission, I can get a solid 90fps basically everywhere at 100% render resolution if I disable text and radar antialising (not sure why this makes such a big difference, but it definitely does according to the oculus performance graph). It seems like if there is more than 1 or two large ships on screen though, the performance drops below 90fps. I still haven't made up my mind if the game feels better with ASW set to auto or to a locked 45FPS. I know I can also play with the steam render resolution to get more performance.
  • The positional tracking feels jittery--it works, but it feels constantly feels like like the cockpit is shaking--especially when the game framerate is below 90FPS. Not sure if there's anything I can do to reduce this effect, other than maximizing the amount of time the game is running at 90FPS, which minimizes, but does not eliminate the issue
  • This mod does not seem designed to work with the turret on the YF-1300. When I man the turret, my head appears locked to the turret bubble (as in my view of the turret doesn't actually change as I would expect with proper headtracking), and I need to use my controller to actually move the turret. Is there some setting I should change just for the turret sections of the game, or is the mod just not designed to be used like this?
Overall, great work--looking forward to playing as much of the singleplayer campaign as I can in VR!

User avatar
Ace Antilles

Admiral (Moderator)
Posts: 4789
Joined: Sat Jan 22, 2000 12:01 am
Contact:

Post by Ace Antilles » Sun Aug 09, 2020 6:53 pm

I don't do VR so I will let Max answer but remember this game was never even meant for high FPS and until recently we had a severe lag bug.
If you can get over 60 FPS you are still doing well in some circumstances.
Chief XWAU Team annoying nitpicker.
Ace Antilles - The X-Wing Outpost
Image

P-Rock
Recruit
Posts: 5
Joined: Sun Aug 09, 2020 12:27 am

Post by P-Rock » Sun Aug 09, 2020 7:20 pm

Ace Antilles wrote:
Sun Aug 09, 2020 6:53 pm
If you can get over 60 FPS you are still doing well in some circumstances.
I'd be happy to run the game frame locked at 45FPS with ASW, but the jitteryness is much more noticeable for whatever reason at the lower framerate. With modern VR games I'll notice visual artifacts when ASW is on, but it still "feels" smooth.

m0rgg
Cadet 3rd Class
Posts: 43
Joined: Wed Apr 01, 2020 10:33 pm

Post by m0rgg » Sun Aug 09, 2020 7:46 pm

I have also noticed the jitter.
If you still have the HUD on, it doesn't shake if I remember correctly.
From this I suspect it has something to do with the reprojection from 2D to 3D, and the fact that the view adjustment is hacked with mouse look.

About the FPS, the CPU is still projecting the geometry with the original code, on the CPU. This is not optimized for high polygon models.
With enough reverse engineering and hooking, maybe this could be bypassed but probably only JeremyaFr can tell.

P-Rock
Recruit
Posts: 5
Joined: Sun Aug 09, 2020 12:27 am

Post by P-Rock » Sun Aug 09, 2020 8:22 pm

m0rgg wrote:
Sun Aug 09, 2020 7:46 pm
I have also noticed the jitter.
If you still have the HUD on, it doesn't shake if I remember correctly.
I believe I have the HUD on (the YF-1300 doesn't have a dynamic cockpit), and I still notice the jitter.

User avatar
blue_max
Lieutenant Commander
XWAU Member
Posts: 1387
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Mon Aug 10, 2020 4:40 pm

Have you tried the tips in this thread to fix the jittering?

https://www.xwaupgrade.com/phpBB3/viewt ... 36&t=12827

Bottom line: lower your SteamVR resolution a little bit and disable Active Cockpit. I believe the jittering may be related to performance.

P-Rock
Recruit
Posts: 5
Joined: Sun Aug 09, 2020 12:27 am

Post by P-Rock » Mon Aug 10, 2020 7:22 pm

blue_max wrote:
Mon Aug 10, 2020 4:40 pm
Have you tried the tips in this thread to fix the jittering?

https://www.xwaupgrade.com/phpBB3/viewt ... 36&t=12827

Bottom line: lower your SteamVR resolution a little bit and disable Active Cockpit. I believe the jittering may be related to performance.
Yea I've tried most of that stuff. I didn't realize the positional jitter and framerate may be directly related (I guess I'm asking too much for ASW to do it's thing with a 20 year old game), so maybe I should be playing with a lower steam resolution.

Also FWIW, I managed to get a fair bit of extra performanc by disabling the new text/radar renderer and antialiasing. Not sure if it was only one setting that actually made a difference, but my performance headroom and framerate shot up significantly when these were disabled.

User avatar
blue_max
Lieutenant Commander
XWAU Member
Posts: 1387
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Mon Aug 10, 2020 7:53 pm

Disabling the text renderer does improve the performance (but we may have a fix for that soon). Let us know if you solved the jittering -- and how. I believe it's related to framerate, but I may be wrong.

I forgot to address your other comment: I'm not sure mouse look works inside the turret, but I'll take a look again. The hook that enables tracking is piggy-backing on top of the mouse look function, so if that's disabled inside the turret, that's why tracking won't work. There might be another way to enable tracking while in the turret, so I'll check.

P-Rock
Recruit
Posts: 5
Joined: Sun Aug 09, 2020 12:27 am

Post by P-Rock » Fri Aug 14, 2020 1:41 am

Turns out it's pretty easy to avoid ever needing to use the turret on the YT-1300/Otana, so I wouldn't sweat it.

I finally past the prologue (I played this game when I was like 12 and could have sworn it wasn't this difficult...), but now there are some new issues associated with the dynamic cockpit:

1. How do I disable the non-dynamic cockpit HUD? I can use ctrl+end, but that also appears to disable the HUD on the dynamic cockpit too.
2. Is there a way to make the dynamic cockpit HUD text more readable? I was doing the Y-wing training mission, and the targeting HUD is damn near impossible to read. The blue text doesn't really stand out very well on the green background, and the text is too small to really read in VR. Can I change the colors or increase the size of the text?

aaadmiral
Cadet 4th Class
Posts: 24
Joined: Fri Apr 17, 2020 8:54 pm

Post by aaadmiral » Sat Aug 15, 2020 2:52 am

haha actually I could never beat this game when I was younger, maybe you were a 12 year old savant!

User avatar
blue_max
Lieutenant Commander
XWAU Member
Posts: 1387
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Sat Aug 15, 2020 3:05 am

P-Rock wrote:
Fri Aug 14, 2020 1:41 am
Turns out it's pretty easy to avoid ever needing to use the turret on the YT-1300/Otana, so I wouldn't sweat it.
It's still something I'd like to fix though :)
1. How do I disable the non-dynamic cockpit HUD? I can use ctrl+end, but that also appears to disable the HUD on the dynamic cockpit too.
When you install the cockpits, there's an option to keep the full HUD, only the text boxes or get rid of the HUD completely. Just run the installer again and select "I don't need the HUD anymore".
2. Is there a way to make the dynamic cockpit HUD text more readable?
For VR try setting "Text2DRendererEnabled = 0" in DDraw.cfg (this will disable the new Text Renderer which, at the moment, is also faster) and then set your in-game resolution to 1024x768 or 1280x1024 or something close to that. I find those resolutions make the text more readable in VR.

Another option is to keep "Text2DRendererEnabled = 1" in DDraw.cfg and then use "TextFontFamily" to select a bigger font from your system. For me, setting "TextFontFamily = Verdana" seems to work OK.

For the specific case of the Y-Wing, open "DynamicCockpit\YWingCockpit.dc" and find the line that starts with "uv_coords = TARGETING_COMPUTER_SRC" and replace it with:

Code: Select all

uv_coords    = TARGETING_COMPUTER_SRC, 0,128, 256,0; 0x0
The last number (0x0) is a hex RGB number that controls the color of the background. Setting it to 0 will make it black.

pimpe
Recruit
Posts: 8
Joined: Mon May 04, 2020 8:59 pm

Post by pimpe » Fri Aug 28, 2020 1:32 pm

Hi all

Just wanted to let you know how I fixed the jittering:
I set the in-game resolution to the minimum of 640x480
It was set to the desktop resolution, which was 3840x1080 for me.
This has no effect to the actual resoluton in VR, but now the jittering is completely gone and overall performance is excellent now in VR.

m0rgg
Cadet 3rd Class
Posts: 43
Joined: Wed Apr 01, 2020 10:33 pm

Post by m0rgg » Fri Aug 28, 2020 1:56 pm

pimpe wrote:
Fri Aug 28, 2020 1:32 pm
Hi all

Just wanted to let you know how I fixed the jittering:
I set the in-game resolution to the minimum of 640x480
It was set to the desktop resolution, which was 3840x1080 for me.
This has no effect to the actual resoluton in VR, but now the jittering is completely gone and overall performance is excellent now in VR.
Thanks or the info!

Did you do it by modifying the .exe or through a .cfg file of the hook?

User avatar
blue_max
Lieutenant Commander
XWAU Member
Posts: 1387
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Fri Aug 28, 2020 9:48 pm

Yeah, thanks for the info, pimpe. I don't see why setting it to 640x480 fixed it, but I added your feedback to the Troubleshooting thread. I suspect that you'd also fix the jittering if you set the in-game resolution to other low values like 800x600 or 1024x768, so you may want to try those as well.

pandabacon
Recruit
Posts: 2
Joined: Thu Oct 22, 2020 5:09 pm

Post by pandabacon » Sat Oct 24, 2020 8:02 am

setting to 640x480 actually really helped. Still getting some jitters when there are large ships but its much better and playable. Its funny because the onscreen text never jitters even when rest of the cockpit is. This really did improve it though.

Post Reply