Page 1 of 11

**NEW** DSUCPv2.4 Release **NEW**

PostPosted: Wed May 02, 2012 7:57 pm
by rogue518
You did a very good job on this the sounds all the updated craft so far... and DTM'S updated Naboo fighter damn!!! ;) very nice
thanks again.


Sincerely, Rogue518

Re: Great Job!!! Darksaber, on the DSUCP v2....

PostPosted: Wed May 02, 2012 8:14 pm
by Darksaber
Your welcome Rogue :) I take it everything worked ok with the installation then??

Re: Great Job!!! Darksaber, on the DSUCP v2....

PostPosted: Wed May 02, 2012 8:45 pm
by rogue518
Yeah, it was a slow download, but I waited until after midnight and I was able to download it. Still took awhile but better than what it was.the only problem I'm having is at the beginning.. the first cutscene... screen is black but I will try to find the right Codecs patch that I need. Also to me, you just did'nt add new ships and make the DSUCP v2... the sounds the ships you've tweaked... great job Darksaber!!!

Sincerely Rogue518

Re: Great Job!!! Darksaber, on the DSUCP v2....

PostPosted: Wed May 02, 2012 9:07 pm
by General_Trageton
Didn't take me too long actually, cable be thanked :)
Won't get around to install today, but I'm looking forward to giving it a serious workout!

Great job, DS! That's one hell of a package noone should miss!

Re: Great Job!!! Darksaber, on the DSUCP v2....

PostPosted: Wed May 02, 2012 9:12 pm
by Darksaber
Rogue did you install the K-lite Codec pack I mentioned?

Cheers GT:)

Re: Great Job!!! Darksaber, on the DSUCP v2....

PostPosted: Wed May 02, 2012 10:03 pm
by Rookie_One1
finally!

downloading right now, will do a run later :)

Re: Great Job!!! Darksaber, on the DSUCP v2....

PostPosted: Wed May 02, 2012 10:12 pm
by rogue518
Yeah I did... 64-bit, I am downloading 32-bit as we speak, will let you know how it turns out.

Sincerely, Rogue518

Re: Great Job!!! Darksaber, on the DSUCP v2....

PostPosted: Wed May 02, 2012 10:14 pm
by Dragon
Great work DS!!! :gott:
The game it self and all cutscenes work well, the only little thing is the first and second introscene as Rogue518 already mentioned.
I've installed the K-Lite Codec Pack, but the first two scenes are still just black screen and audio.
The option to skip the intro, (...XwingAlliance\XwingAlliance.exe" /skipintro ) dosn't seem to work with Runfrist.

Re: Great Job!!! Darksaber, on the DSUCP v2....

PostPosted: Wed May 02, 2012 10:27 pm
by rogue518
Still no luck on the 2 cutscenes.... will try to figure this out..... ;)


Sincerely, Rogue518

Re: Great Job!!! Darksaber, on the DSUCP v2....

PostPosted: Wed May 02, 2012 10:31 pm
by starflame
Also voicing my support, great job on the new pack. Great content and easy installation!

Re: Great Job!!! Darksaber, on the DSUCP v2....

PostPosted: Wed May 02, 2012 10:38 pm
by Darksaber
Dragon use this in your shortcut to skip the cutscenes

C:\Windows\System32\cmd.exe /C start "" /affinity 01 "C:\Program Files (x86)\LucasArts\X-Wing Alliance\XwingAlliance.exe" /skipintro

It does the same as runfirst without using runfirst


I still can't figure out why the cutscene aren't playing I've uninstalled all the Video codec on my machine including K-Lite

Yes the cutscenes didn't work, but as soon as I install the K-lite Codec pack the cutscene worked again, this is starting to bug me now,

Why it is working on my PC and no one else's.

Re: Great Job!!! Darksaber, on the DSUCP v2....

PostPosted: Wed May 02, 2012 11:33 pm
by Darksaber
Ok If people would please test this for me

First download VirtualDub Release build -- 1.9.11 (stable), 32-bit (x86) version

from here http://virtualdub.sourceforge.net/ unzip the VirtualDub-1.9.11.zip file run VirtualDub.exe and browse to the XWA Movies dir C:\Program Files (x86)\LucasArts\X-Wing Alliance\Movies

and open LogoFinal.avi

If you get this error message
virtualdub.jpg
virtualdub.jpg (65.28 KiB) Viewed 8170 times


Close it and Download K-Lite Codec Pack http://www.codecguide.com/download_kl.htm the MEGA PACK and Install it

Open VirtualDub again and try to open the LogoFinal.avi, if the file opens theoretically it should run in XWA

Open XWA and see if you see the first cutscene

I would appreciate your help so please report back, Thanks

Re: Great Job!!! Darksaber, on the DSUCP v2....

PostPosted: Thu May 03, 2012 1:47 am
by rogue518
Yep, that fixed it for me Darksaber.... I really like it. Thanks for the info to fix it. Just to let you know I completely got out of XWA and restarted it, and it came on. Now Dragon said it was 2 cutscene I only saw 1 but what I saw was really cool!!!! :D

Sincerely, Rogue518

Re: Great Job!!! Darksaber, on the DSUCP v2....

PostPosted: Thu May 03, 2012 1:53 am
by Darksaber
No it's only 1 cutscene, and thanks, hopefully this will solve everyone's problem

If you had installed the Imperial concourse there are 6 videos all to do with the concourse

Re: Great Job!!! Darksaber, on the DSUCP v2....

PostPosted: Thu May 03, 2012 3:48 am
by Bman
I forgot to check, but does the K-Lite Codec Mega pack include the Microsoft MPEG-4 V.3 Video codec ?
That thought crossed my mind. I know it was used in TFTC .avi cutscenes.
I have both packs installed, but the MPG4c32.dll codec is still available at http://www.undercut.org/download/
May not be relevant to this thread though ?

One way to check to see what codecs are being used (or missing) is to open the .avi file with Virtual Dub video editor as DS mentioned above, then click the "File" pull-down menu, then select the "File Information..." option.
Also, a great way to see all of the different video compression type codecs you have on your system is to click on the Video pull-down menu in Virtual Dub and then select "Compression..." option. Each it's own quality.

Another solution... there is also a great free video editor called "FreeMakeVideoConverter.com" that can pretty much open up and play most video formats and you can then save them in whatever format or codec you want, perhaps uncompressed, then compress them with Virtual Dub using a universal codec you already have. But again, these are extra last-ditch efforts you probably won't need to do if you follow precisely the solutions DS mentioned in the above threads. This all works on Win 32 bit systems, but I'm not sure about 64-bit platforms.

Re: Great Job!!! Darksaber, on the DSUCP v2....

PostPosted: Thu May 03, 2012 5:25 am
by Darksaber
Hi Bman,

Not sure about K-Lite Codec Mega Pack including the Microsoft MPEG-4 V.3 Video codec I would have thought so

And Undercut's MPG4c32.dll doesn't work either, I don't know if it ever did??????

I have found another solution though if people do not want to download the K-Lite Mega Pack and that is to download the FFDShow MPEG-4 Video Decoder from here http://www.free-codecs.com/download/FFDShow.htm

I've tested it making sure the K-lite Mega Pack was uninstalled first testing the cutscene in game (which didn't show)
Installing the FFDShow MPEG-4 Video Decoder and testing again the cutscene worked :)

Re: Great Job!!! Darksaber, on the DSUCP v2....

PostPosted: Thu May 03, 2012 7:21 am
by n8weigel
Wonderful job DS! I love the new sound effects! They sound very movie-like.

However, I have noticed a few sound issues where sound WAV files might have been mixed up somewhere along the way. When flying in the Otana in a campaign mission, I was using the F key to fire turrets at my current target. The sound that was played sounded more like S-Foils locking into position. There have been a few other sounds that seem out of place as well. For example, when entering hyperspace and when setting laser/shield recharge levels, the sounds didn't seem to match up with what I anticipated. This could just be my idea of what it should sound like conflicting with yours. I just wanted to get my two cents in and make sure everything functions the way you want it to function.

Lastly, I noticed the in-flight music to be different during a campaign mission. When a mission is complete, the music usually reverts to something mellow and just filler music as you fly back to your command ship. With the DSUCP 2.0, there seems to be exciting music all they way until I quit the mission. It just seems out of place.

Now, the only reason I bring these things up is because I'm guessing they're little details that may have been missed along the way towards creating such a magnificent, catch-all installer. I thank you very much for going through all the effort and setting aside all the time to make something like this possible. Thanks in advance for checking out the few issues I've noticed thus far. Everything else has been working smoothly for me!

Nate

Re: Great Job!!! Darksaber, on the DSUCP v2....

PostPosted: Thu May 03, 2012 9:19 am
by Dragon
DS, i can play the intro in VirtualDub (Looks damn good! :thumbs: ), but in XWA the game is minimized to the taskbar and i have to restore it and skip the rest of the first intro. But the skip-intro shortcut worked, so this do the trick for me.

However, i just stumbled over an real error. The StrikeCruiser OPT is faulty, it causes triangling-to-infinity.
The version 1.1 of the StrikeCruiser dosn't have this problem.

flightscreen1.jpg
flightscreen1.jpg (96.74 KiB) Viewed 8122 times

Re: Great Job!!! Darksaber, on the DSUCP v2....

PostPosted: Thu May 03, 2012 10:05 am
by Darksaber
Thanks for the feed back Nate, I've taken on board what you have said and listened to the wave files your referring too along with some others I wasn't happy about, I've either removed them from the pack or replaced them with better sounding files.

Rookie_One1 also reported the the rebel and Imperial lasers when on full charge sounded like turbo lasers, I replaced these also, and fixed the firing pattern of the Xwings.

The inflight music is still the original music no change there, the only change to the music is if you have the Imperial Hangar installed and the only msic that has changed is on the concourse and various rooms, the inflight music is the original, and has not been replaced.

The Wave sounds are from various sources, and it seems some got mixed up, I apologise for that. I should have really released the DSUCPv2.0 to beta testers, but there aren't that many people about these days willing to test thing, so I appreciate all of this feedback.

Thanks Dragon, must have missed that, I see what you mean, must have been an older version I had in the UCP craft folder, thanks for spotting that :D

I'm really sorry about this but I'm compiling a new version of the DSUCPv2.0 with the fixes.

A new version of the DSUCPv2.0 will be available soon I'll post an update on my news page when it's up

Again sorry :(


For now I'll take it off my site

Re: Great Job!!! Darksaber, on the DSUCP v2....

PostPosted: Thu May 03, 2012 8:27 pm
by Dragon
The LAAT has also an triangling-to-infinity problem and it crashes the game when it's been hit.

Re: Great Job!!! Darksaber, on the DSUCP v2....

PostPosted: Thu May 03, 2012 9:19 pm
by Darksaber
Cheers Dragon, fixed that, don't know why it did it, but when I installed a fresh copy over it, no triangulation and no crash weird, I'll test it again when I do an install of the UCP see what happens

Thanks though, your a good 'n' :)

Re: Great Job!!! Darksaber, on the DSUCP v2....

PostPosted: Thu May 03, 2012 9:40 pm
by Darksaber
Ok I need a couple of Testers

Instead of upping the whole UCP to test the MPEG-v4 Codec's and find out they don't work, I've made a small app to install them, but you must have the UCPv2.0 installed

I need someone with Windows 7 x64 as there OS and I need someone with Windows XP x32 to test please

The reason why is I know that some people with Win7 x64 are having a problem viewing the cutscene

this installer only installs 4 files to the System32 (WinXP, Win7 x86 32bit system) and on a X64 system it should install them to the SysWOW64 folder

C:\Windows\System32 or C:\Windows\SysWOW64

I've used them before in the UCPv1.1 and they are perfectly safe and fine

The files are

MSAud32.acm
MPG4ds32.ax
MSAdds32.ax
MPG4c32.dll

Would anyone with either of the above mentioned Operating systems be willing to install them and see it they are in either you system32 or SysWOW64 folder and of course see if the cutscene will play please :)

You can delete them if you wish afterwards quiet safely from the above mentioned folders

I would be very grateful if a few people could do this and report back if the cutscene plays or not Please

[EDIT] Link removed

Re: Great Job!!! Darksaber, on the DSUCP v2....

PostPosted: Thu May 03, 2012 10:05 pm
by Rookie_One1
Windows 7 X64 here and i just tested it

it works well

Re: Great Job!!! Darksaber, on the DSUCP v2....

PostPosted: Thu May 03, 2012 10:06 pm
by Darksaber
Was the cutscene working before you installed it though??

And thanks

Re: Great Job!!! Darksaber, on the DSUCP v2....

PostPosted: Thu May 03, 2012 10:15 pm
by Rookie_One1
was because I had the CCCP pack, when i removed it, stop working (for the need of the cause), then I installed the small fix, start to work again