HOTAS/Joystick will not respond

Need help with hardware? Game doesn't run? System wont boot? We might be able to help!

Moderators: Darksaber, Forceflow, decoy

Post Reply

HOTAS/Joystick will not respond

Posts: 3
Joined: Wed Sep 04, 2019 5:57 pm

Post by Slyrunner » Thu Sep 12, 2019 2:18 am

Hey all!

So, I installed XWAU just tonight and when I went to play, my X-56 Rhino did not respond in the slightest. After doing some research, I found that I needed to download a ddraw.cfg update. Well, when I tried the latest, and second to latest, it still didn't work, regardless as to what I had the JoystickEmul = X set to (I tried -1, 0, 1).

Am I missing something here? Does the game offer support to HOTAS? Or even just the joystick? If it works with my throttle as well, that'd be fantastic!

Thanks all!

User avatar
Lieutenant JG
Galactic Empire
Posts: 604
Joined: Wed Sep 24, 2008 2:23 am

Post by ual002 » Thu Sep 12, 2019 9:33 pm

I had issues with the game seeing both the Stick and throttle of my Rhino at the same time out of the box, so I ended up using some joystick emulator to combine their inputs. It ended up being well more work than necessary and reverted back to my X-52 pro.

If we can ever find a way to have XWA support joysticks natively like the rhino, I would support it, as it was a really nice setup.
For the glory of his majesty Emperor Palpatine! Image Image Image Image

Post Reply