[Solved] Ultrawide res - Disappearing meshes

Any issues with the XWAU or X-Wing Alliance? Please let us know here!
Post Reply

[Solved] Ultrawide res - Disappearing meshes

dezmond
Recruit
Posts: 4
Joined: Mon May 06, 2019 5:37 pm

Post by dezmond » Thu Apr 15, 2021 9:28 pm

Hi folks,

I did a fresh install of XWAU 2020, with the 2.1 bundle patch, and first please let me say how impressive it is, the progress and changes are remarkable! :D

I noticed an issue when trying to run at 3440x1440 (21:9), where I noticed the SSD mesh can disappear at certain distances/angles - most notably at the beginning of 'Mining Colony Under Siege', where looking left pops in/out the SSD model when moving the camera.
I'm using all the hooks as included in the 2.1 patch, and set the IsAutoResolutionEnabled = 1 in Hooks.ini , which is where I see the behaviour - but with this value at 0 and an aspect ratio of 16:9, this displays fine (no issue).

I also tried setting the resolution via xwahacker-qt manually to 3440x1440 and encountered the same behaviour.

Is there any workaround for the models display for the ultrawide aspect ratios?

Cheers,
Dez
Last edited by Ace Antilles on Sun Apr 18, 2021 2:23 pm, edited 1 time in total.
Reason: Solved

User avatar
blue_max
XWAU Member
Posts: 1677
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Fri Apr 16, 2021 5:17 am

I think the problem here is that XWA's engine was not coded to handle these ultrawide resolutions, so it's clipping the sides of the screen where they would be if you were running on a 4:3 screen ratio. I'm not sure this can be helped as that would probably require a new hook and deep knowledge about XWA's clipping code (which we probably don't have).

What you can do is adjust the FOV so that it's not so large, but keeping your current ultrawide resolution. You can adjust the FOV in real time by pressing Ctrl+Alt+Shift + Left/Right arrows. If your FOV is set to, say, 100 degrees, lower it down to about 86 degrees or less. The FOV can be adjusted per craft, so you'll probably have to adjust a few cockpits -- but this should be a one-time-only thing. Settings are saved, so just jump on each craft on a skirmish mission, fix the FOV and you should be done.

Also, if you lower your FOV, you'll see less distortion anyway.

dezmond
Recruit
Posts: 4
Joined: Mon May 06, 2019 5:37 pm

Post by dezmond » Sat Apr 17, 2021 1:47 pm

Thanks, adjusting the FOV resolved the pop-in issue.

I'd been using the default 16:9 FOV, which in this case I think was around 86 (so the ultrawide was maintaining the same view as 16:9, but effectively just adding data as Hor+ to each side), but with some adjustments in this mode it's now displaying the models as expected.

Post Reply