Joystick spinning hard left, unplayable game.

Any issues with the XWAU or X-Wing Alliance? Please let us know here!
Post Reply

Joystick spinning hard left, unplayable game.

UJSMaster
Recruit
Posts: 1
Joined: Mon Apr 19, 2021 4:39 am

Post by UJSMaster » Mon Apr 19, 2021 4:44 am

My first post! Woot!

I've been using XWAU every now and then over the years and I think the project is great!

Anyway, I have a 4 year old boy that loves Star Wars and their ships and I thought I'd introduce him to it. I just bought it again off Steam. I have it on Steam on another account, on GOG, bought originally in the 90s, etc.

So I upgraded vanilla with mega pack and update 2, and when I try to play, the ships goes into a very fast left spin as if the spin button is pushed and the joystick is set to hard left. So to try to correct the issue, I installed the drivers for the joystick (Logitech Attack 3), but the issue is the same. During calibration in the Logitech Game App, the joystick works perfectly. No veering, all buttons work. Very solid Joystick.

The issue must be with the Upgrade project. How can I fix this? I really want to show my boy a game I played when I was a kid.

Thanks!

Edit 1: must note this is the Steam version I'm using, and I'm running "alliance.exe" straight from Windows Explorer, not through Steam.

Edit 2: here's a YouTube video (https://www.youtube.com/watch?v=DHDvYYFNKYI) of the issue. You can see the left spin. When I press down on the "spin" button, you can see the ship then starts rolling hard left. So that's two issues (1: the left veer, and 2: as if the spin button is pressed).

User avatar
ual002
XWAU Member
Posts: 897
Joined: Wed Sep 24, 2008 2:23 am

Post by ual002 » Mon Apr 19, 2021 2:10 pm

You need to configure your joystick in the joystick configurator.

A recent program was introduced to allow more buttons and axis' on more modern joysticks. As a result you have to do a little tweaking, but its worth it.
Image Image Image Image Image

Omadon
Recruit
Posts: 9
Joined: Fri Apr 23, 2021 12:42 am

Post by Omadon » Fri Apr 23, 2021 12:47 am

I had the same problem.

You must enter the configuration menu and disable "Use Rudders" which is ON by default.

The spin will then go away immediately.

Post Reply