Transfer Laser Energy to Shields Bug

Any issues with the XWAU or X-Wing Alliance? Please let us know here!
Post Reply

Transfer Laser Energy to Shields Bug

User avatar
the_stag
Cadet 1st Class
Posts: 101
Joined: Sun Jun 14, 2020 3:47 pm

Post by the_stag » Fri Jan 21, 2022 5:22 pm

When I use the quote " button to transfer laser energy to shields, my shields go up even if there's no laser power remaining. I thought it had to do with some of the hook modifications and/or xwingalliance.exe patching I have been doing. So I completely removed/uninstalled XWA and XWAU 2020 to remove whatever issue I created. Upon installing XWA vanilla (I tried with the GOG version and CD version with and without update 2.02) I launched the game with no modifications and the issue exists in the original as well.
The difference is that when I map the button to my joystick hat, it only sends one key press in vanilla, but with XWAU2020 it sends multiple presses as long as I hold it. I'm using a Logitech Extreme 3D Pro joystick. But if I manually press " on my keyboard I can get back to full shields with no laser power, it just takes a little while. Using the joystick it's a quick shield recovery (depending on the craft). I've also verified that this does not happen with the apostrophe ' key, only quotes ".

Has anyone else ever noticed this? Can anyone else verify this is happening to/for them? Is there a way to fix this? Am I uncovering some kind of giant conspiracy and now I need to lock the doors and fear for my well being? I'm beginning to question everything I thought I ever knew about this game. Save me from myself!

Post Reply