New effects and installers

This is the XWA Upgrade Forums! In here you'll find some of the most talented 3D modellers and texture guys on the net!

Moderators: Darksaber, General_Trageton, K_Kinnison

Post Reply

Re: New effects and installers

User avatar
keiranhalcyon7
Lieutenant JG
Posts: 530
Joined: Tue Jan 02, 2018 6:41 am

Post by keiranhalcyon7 » Sun May 17, 2020 8:09 am

General_Trageton wrote:
Fri May 15, 2020 5:02 pm
That might actually work, I recall there was a modified Endor mission, where you actually got to fly as Wedge rather than the Falcon.
Was way more forgiving in terms of room to maneuver XD
I vaguely recall a debate from waaaaaay back over how big to make the XWAUP Falcon. IIRC, the TG Falcon was significantly undersized, but sizing the ship correctly dramatically increased the difficulty of the final mission. Anyone remember the outcome of that discussion?

User avatar
Ace Antilles
Captain
XWAU Member
Posts: 3560
Joined: Sat Jan 22, 2000 12:01 am
Contact:

Post by Ace Antilles » Sun May 17, 2020 1:06 pm

keiranhalcyon7 wrote:
Sun May 17, 2020 8:09 am
General_Trageton wrote:
Fri May 15, 2020 5:02 pm
That might actually work, I recall there was a modified Endor mission, where you actually got to fly as Wedge rather than the Falcon.
Was way more forgiving in terms of room to maneuver XD
I vaguely recall a debate from waaaaaay back over how big to make the XWAUP Falcon. IIRC, the TG Falcon was significantly undersized, but sizing the ship correctly dramatically increased the difficulty of the final mission. Anyone remember the outcome of that discussion?
I can tell you I've only been messing with it on Invincible but it is a really tight fit lol I think it could be doable.
The time limit is the tough one
Chief XWAU Team annoying nitpicker.
Ace Antilles - The X-Wing Outpost
Image

User avatar
General_Trageton

Fleet Admiral (Administrator)
Posts: 12696
Joined: Fri Apr 27, 2001 11:01 pm
Contact:

Post by General_Trageton » Sun May 17, 2020 1:20 pm

There's a few ships that were resized to match the movie originals, like the bloody shuttle, whicin combination with the Space Colony 2 h became a gamebreaker, as it no longer fit through the hangar tunnels. As a result I nowadays use the shuttle as a benchmark for scaling hangars. Ah good times XD
Your ship, Captain. I need a drink. - Vince Trageton
Vince T's Modding HQ | My Steam Workshop
Vince T's X-Wing HQ New VXHQ Website WIP

User avatar
Darksaber

Fleet Admiral (Administrator)
Posts: 10875
Joined: Mon Jan 10, 2000 12:01 am
Contact:

Post by Darksaber » Sun May 17, 2020 1:57 pm

Just a thought has anyone ever just tried rescaling the individual DS Tunnel opts? I've just imported a few and you would have thought they might be in some sort of jigsaw arrangement, (one next to the other) but they aren't, they are all centred around 0, 0, 0 or there abouts.

Each opt either has an AccStart or AccEnd hardpoint on them, so my theory is that they use these hardpoints to all fit together forming the tunnels and so on, I'm really not sure, either it's the hardpoints or it could possible be hardcoded I don't know?????

Rescaling the opts might work and they might still fit together, again I don't know????????????? Each opt would have to be rescaled to the same percentage or multiple

There are 56 opt to be rescaled, and I don't even know if it would work, when the final opt is rescaled, it might just be a giant waste of time if it didn't work.

Optech works on percentage when rescaling, XWA Opt Editor I thing work in multiples of meters (I think) I haven't messed around with scaling it that, so it would need to be explained.

Could work I duuno!
“You can please some of the people all of the time, you can please all of the people some of the time, but you can’t please all of the people all of the time”.”
- John Lydgate

Good Things Come To Those Who Wait....
Darksaber's X-Wing Station

Bman
Lieutenant
Posts: 844
Joined: Mon Apr 05, 2004 11:01 pm

Post by Bman » Sun May 17, 2020 6:17 pm

Dornil wrote:
Sat May 16, 2020 9:58 pm
Right! It was due to TIR being off. Now everything seems to work and it is just... wow! I never thought that this kind of stuff will ever be possible in XWA!
BTW, can a TIE Fighter conversion work with all those improvements?
Yes. We're working on it. Also waiting for all of these crafts to get "finished" dynamic cockpits/effects and all the bugs worked out so it everything can be included. No ETA yet.
W-I-P: ISD-II, XQ-1 Platform1, (Imp) Escort Carrier, Misc, & TFTC.

Bman
Lieutenant
Posts: 844
Joined: Mon Apr 05, 2004 11:01 pm

Post by Bman » Sun May 17, 2020 6:25 pm

DS, those .opt models you're referencing... if they can be altered, I was thinking they could even be replaced with DS-1 surface models, buildings and a trench run for DTM's new DS-1 model. Huge project. But would be interesting. They reside in the Equipment0.lst file. If AlliED could reference them via .tie mission file, then it would be easier to see how they look. Perhaps replace with existing model with one of those. It's just reading from the right table index. Does Jeremy's new 3D mission editor read all .opt files ?
W-I-P: ISD-II, XQ-1 Platform1, (Imp) Escort Carrier, Misc, & TFTC.

Yautja Hunter
Recruit
Posts: 6
Joined: Tue Jun 02, 2020 6:20 pm

Post by Yautja Hunter » Tue Jun 02, 2020 7:28 pm

Hi guys!

Maybe some one can help me. I am using fresh installation of XWA GOG. Installed XWAUCP_v1.6. The resolution is set to 1920x1200 via XWAHacker tool (also tried using 1600x900, as was suggested some where on this forum, but that didn't help). I am playing the very first mission with YT-1300 Transport.

Currently I have two issues:

1) I see black bars in the sky and strange aura around planet (see attached screenshots). They were not present when only XWAUCP 1.6 was installed.
2) If I install EffectsByBlueMax_v1.1.3.1 - the cockpit and the space station I depart from - turn black (see attached screenshot).

My specs are: GTX 1080Ti, GeForce Driver 446.14, Win 10 x64

Any help would be greatly appreciated. Thanks!
You do not have the required permissions to view the files attached to this post.

User avatar
Ace Antilles
Captain
XWAU Member
Posts: 3560
Joined: Sat Jan 22, 2000 12:01 am
Contact:

Post by Ace Antilles » Tue Jun 02, 2020 7:39 pm

Those are the new lighting effects from the EffectsByBlueMax_v1.1.3.1 I believe.
I think the reason you are seeing that is because you are missing a few essential installation upgrades first. Which might not have been made clear.

First install the Super Backdrops Version 2.1. Then the Rebel and TIE cockpits.
After that make sure you use XWA Hooks Setup and copy over all the updated Hook files.
Once you have done that then it hopefully will be fixed.
Chief XWAU Team annoying nitpicker.
Ace Antilles - The X-Wing Outpost
Image

Yautja Hunter
Recruit
Posts: 6
Joined: Tue Jun 02, 2020 6:20 pm

Post by Yautja Hunter » Wed Jun 03, 2020 8:59 am

Nope, didn't work.

Here is what I did:

1. Installed XWA GOG
2. Installed XWAUCP_v1.6 (chose 1920x1080 resolution) - black bars in the "sky" are already present at this stage.
3. Installed Super Backdrops Version 2.1
4. Installed RebelDynamicCockpits_v2.0 (all by default)
5. Installed TieDynamicCockpits_v1.0 (all by default)
6. Installed EffectsByBlueMax_v1.1.3.1 (all by default)
7. Ran XwaHooksSetup, it created Hooks and Setup folders. Copied all files from Setup folder to XWA folder overwriting everything.
8. Ran the game and still have same black glitches as on the screenshots above.

P.S. I did not use XWAHacker tool this time.
P.P.S Actually, I am getting those black bars right after installing XWAUCP_v1.6 (i.e. BEFORE I install any other effects mods)

User avatar
blue_max
Lieutenant
XWAU Member
Posts: 964
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Wed Jun 03, 2020 4:37 pm

Yautja Hunter wrote:
Wed Jun 03, 2020 8:59 am
2. Installed XWAUCP_v1.6 (chose 1920x1080 resolution) - black bars in the "sky" are already present at this stage.
...
P.S. I did not use XWAHacker tool this time.
P.P.S Actually, I am getting those black bars right after installing XWAUCP_v1.6 (i.e. BEFORE I install any other effects mods)
OK, help us understand this step. You installed the GoG version, then XWAUPC 1.6 and you got the black bars right away. At this point, you shouldn't update the hooks or use xwahacker to modify the resolution. The install should work "as is". Do you have multiple video cards in your machine?

What I would suggest is clean GoG install + XWAUP 1.6 and then refresh the hooks to the latest version if you see artifacts.

Yautja Hunter
Recruit
Posts: 6
Joined: Tue Jun 02, 2020 6:20 pm

Post by Yautja Hunter » Wed Jun 03, 2020 5:40 pm

No, I don't have multiple cards in the system, just one GeForce GTX 1080Ti (unless you count the video processоr embedded into Core i7-8700K).
So, I checked again. I am getting black bars right after installing XWAUPC 1.6. As you recommended, I updated all the hooks via XwaHooksSetup and tried to launch the game. It starts properly, I can go to quarters, select my mission, but then the game drops out without any errors into Windows on mission loading.

User avatar
blue_max
Lieutenant
XWAU Member
Posts: 964
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Wed Jun 03, 2020 7:01 pm

Yautja Hunter wrote:
Wed Jun 03, 2020 5:40 pm
I can go to quarters, select my mission, but then the game drops out without any errors into Windows on mission loading.
You don't see a crash report in the Windows Event Viewer? Can you look in %localappdata%\crashdumps to see if there are any xwingalliance*.dmp files in there?

Yautja Hunter
Recruit
Posts: 6
Joined: Tue Jun 02, 2020 6:20 pm

Post by Yautja Hunter » Wed Jun 03, 2020 8:18 pm

Yes, there a many of them, including the latest. Can I attach it here in archive?

User avatar
Ace Antilles
Captain
XWAU Member
Posts: 3560
Joined: Sat Jan 22, 2000 12:01 am
Contact:

Post by Ace Antilles » Wed Jun 03, 2020 8:22 pm

Yautja Hunter wrote:
Wed Jun 03, 2020 8:18 pm
Yes, there a many of them, including the latest. Can I attach it here in archive?
Type eventvwr in your Windows start menu or search bar.
Go to Windows Logs - Application and look for the Application Error

You should see something like this with lots of Faulting lines below etc.
Faulting application name: XwingAlliance.exe, version: 2.0.0.2, time stamp: 0x3765a9b7

Select it all and copy it and then paste into this post. That should help.
Thanks a lot
Chief XWAU Team annoying nitpicker.
Ace Antilles - The X-Wing Outpost
Image

Yautja Hunter
Recruit
Posts: 6
Joined: Tue Jun 02, 2020 6:20 pm

Post by Yautja Hunter » Wed Jun 03, 2020 8:46 pm

Faulting application name: XwingAlliance.exe, version: 2.0.0.2, time stamp: 0x3765a9b7
Faulting module name: XwingAlliance.exe, version: 2.0.0.2, time stamp: 0x3765a9b7
Exception code: 0xc0000005
Fault offset: 0x0019d823
Faulting process id: 0x551c
Faulting application start time: 0x01d639e42cd39dff
Faulting application path: G:\Games\Star Wars - X-Wing Alliance\XwingAlliance.exe
Faulting module path: G:\Games\Star Wars - X-Wing Alliance\XwingAlliance.exe
Report Id: 267b0017-22db-45f7-828b-fe84303d419b
Faulting package full name:
Faulting package-relative application ID:

- EventData

XwingAlliance.exe
2.0.0.2
3765a9b7
XwingAlliance.exe
2.0.0.2
3765a9b7
c0000005
0019d823
551c
01d639e42cd39dff
G:\Games\Star Wars - X-Wing Alliance\XwingAlliance.exe
G:\Games\Star Wars - X-Wing Alliance\XwingAlliance.exe
267b0017-22db-45f7-828b-fe84303d419b

Yautja Hunter
Recruit
Posts: 6
Joined: Tue Jun 02, 2020 6:20 pm

Post by Yautja Hunter » Wed Jun 03, 2020 8:48 pm

Fault bucket 834140712, type 1
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: XwingAlliance.exe
P2: 2.0.0.2
P3: 3765a9b7
P4: XwingAlliance.exe
P5: 2.0.0.2
P6: 3765a9b7
P7: c0000005
P8: 0019d823
P9:
P10:

Attached files:
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER7C49.tmp.dmp
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER7D15.tmp.WERInternalMetadata.xml
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER7D26.tmp.xml
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER7D24.tmp.csv
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER7D54.tmp.txt

These files may be available here:
\\?\C:\ProgramData\Microsoft\Windows\WER\ReportArchive\AppCrash_XwingAlliance.ex_ecc7c0679ee8d82f6b9a8cd78d627ac86fe3eadf_35d6de86_5f68bdef-3991-4960-83fc-029ad2557034

Analysis symbol:
Rechecking for solution: 0
Report Id: 267b0017-22db-45f7-828b-fe84303d419b
Report Status: 268435456
Hashed bucket: f15583453667c413099a370ab5e1e664
Cab Guid: 0

User avatar
Ace Antilles
Captain
XWAU Member
Posts: 3560
Joined: Sat Jan 22, 2000 12:01 am
Contact:

Post by Ace Antilles » Wed Jun 03, 2020 11:01 pm

Yautja Hunter wrote:
Wed Jun 03, 2020 8:18 pm
Yes, there a many of them, including the latest. Can I attach it here in archive?
If you don't get a reply tomorrow about your crash log it's better to repost in the Software forum. Thanks
viewforum.php?f=10
As we know it's not an effects issue now it will be seen better there. Unless an Admin can split it off.
Chief XWAU Team annoying nitpicker.
Ace Antilles - The X-Wing Outpost
Image

Post Reply