[Help] Black Screen on Game Start

Here you can find help for how to best run and setup your XWA VR experience.
Post Reply

[Help] Black Screen on Game Start

theymightbedavis
Recruit
Posts: 9
Joined: Thu Dec 30, 2021 1:20 pm

Post by theymightbedavis » Thu Dec 30, 2021 1:32 pm

Thanks for creating such an awesome work!

I am having a problem with starting the game via Steam VR. When I start it, the game displays only a full black screen. I can hear the sounds of the normal rebel cruiser lobby, and if I press esc, I hear the menu sound (and must guess what is selected in order to exit the game with the screen blackened). However, everything is black.

I have recently installed:
XWAU 2020 Main Upgrade
XWAU Patch 5.0
Effects by Blue Max 12-29-2021 (installed by copying the contents of the unzipped folder into the X Wing Alliance folder and replacing the files that were already there - 7 replacements I think it was).

I used the Babu Frick Configurator to enable Steam VR.

I tried launching the game from Steam VR, and I get the black screen. If I launch the game from the desktop, the screen is also totally black.

The game worked perfectly for me previously without the VR enablement, as a game displayed on my computer screen.

I am streaming the game from a Shadow PC, with Virtual Desktop and Steam VR driving the Shadow's connection to my Oculus Quest 2. This has worked well for Squadrons and House of the Dying Sun, so I know it's possible to do VR through Steam VR with this set up.

Please help! I would love to be able to play this in VR!

User avatar
m0rgg
XWAU Member
Posts: 157
Joined: Wed Apr 01, 2020 10:33 pm

Post by m0rgg » Thu Dec 30, 2021 3:48 pm

Hi,
If I understand correctly, you have a black screen both in the headset and the monitor.
Have you tried alt-tabbing out and back to the game? Sometimes there are issues with the focus.
Usually I start SteamVR separately, and the run the game with xwingalliance.exe or from the launcher (alliance.exe).

User avatar
blue_max
XWAU Member
Posts: 2141
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Thu Dec 30, 2021 8:31 pm

In addition to what m0rgg said, try tapping the period key twice while looking straight ahead. This will re-center your headset (maybe the problem is that the system thinks you're looking backwards?)

Have you tried looking around to see if anything is displayed in any direction?

theymightbedavis
Recruit
Posts: 9
Joined: Thu Dec 30, 2021 1:20 pm

Post by theymightbedavis » Sat Jan 01, 2022 11:10 am

Thank you for replying. I'm afraid that I have not had any luck with these suggestions - alt tabbing out and back in still lands me in the black screen, and attempting to look around ( and to the back etc) or re-center by double tapping the period key do not get me out of the black screen. I can hear the music of the lobby, but moving the mouse around does not get any response (e.g. mousing everywhere to see if it goes over the doors that open or emkay droid who says something).

Please let me know if you have any ideas on what might be going on.

User avatar
m0rgg
XWAU Member
Posts: 157
Joined: Wed Apr 01, 2020 10:33 pm

Post by m0rgg » Sat Jan 01, 2022 12:06 pm

Have you tried starting SteamVR yourself, and putting on the headset to check that it's showin something in the headset?
You should see the SteamVR grid. Then, start the game and verify that you get a loading window.

Another thing you can try is to play the game in non-VR mode to isolate the problem and ensure its not due to the streaming from Shadow PC.

theymightbedavis
Recruit
Posts: 9
Joined: Thu Dec 30, 2021 1:20 pm

Post by theymightbedavis » Fri Jan 14, 2022 8:01 am

Thank you for your help - I've been able to get it to work, and I am now able to see through the headset.

When I copied and pasted in the files for Blue Max's Effects, I took the old HookCockpit and draw.dll (don't remember the exact names) and moved them into a new folder I created which was still located within my XWA directory. I have moved that folder out of the XWA directory, and now it seems to be working normally.

Post Reply