X-Wing Alliance VR mod

Here you can find help for how to best run and setup your XWA VR experience.

Re: X-Wing Alliance VR mod

User avatar
blue_max
Lieutenant Commander
XWAU Member
Posts: 1290
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Mon Jul 20, 2020 5:05 am

Trevor wrote:
Sun Jul 19, 2020 6:14 pm
great news that settings such as positional_x_multiplier and 3d_window_size are no longer required (or used) and my rendering looks awsome.
Thanks for your tests, Trevor. Did you notice any difference in performance between the version from July 17 and 19?

Those illumination artifacts are quite awful. The position of the sun is dictated by the mission. What mission is this? If it's a skirmish mission, can you save it and post it? Does it happen all the time? Does it matter what OPTs are loaded?

@aaadmiral: Yes, we have plans to move to OpenXR. Hopefully that'll help :) Did you try the version from July 19?

User avatar
Trevor
Ensign
Posts: 406
Joined: Thu Dec 04, 2014 7:11 pm

Post by Trevor » Mon Jul 20, 2020 6:03 pm

Whoops.... My bad... It was my config...
For some odd reason I had 0.0.000125... as one of my values...
Just to verify I'll post a pic of it working again

So sorry,
Trev

User avatar
blue_max
Lieutenant Commander
XWAU Member
Posts: 1290
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Tue Jul 21, 2020 1:36 am

No problem Trev, let me know if changing that setting fixed the illumination bug.

So, I reinstalled SteamVR and it seems to be working fine for now. I've been testing both the version from July 17 and 19 and I only see minor differences in performance. Again, I'm relying on people here to report that the version from July 19 is OK/performs better.

User avatar
Trevor
Ensign
Posts: 406
Joined: Thu Dec 04, 2014 7:11 pm

Post by Trevor » Tue Jul 21, 2020 9:06 pm

I don't see a Jul 19 version...?
There is only a Jul 17 version (your dropbox and XWAU Downloads)

Yeah, Lighting is working

Trev
You do not have the required permissions to view the files attached to this post.

User avatar
blue_max
Lieutenant Commander
XWAU Member
Posts: 1290
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Wed Jul 22, 2020 5:37 am

Trevor wrote:
Tue Jul 21, 2020 9:06 pm
I don't see a Jul 19 version...?
I changed the naming convention to make it compatible with this site's Downloads section.

But, nevermind, I just uploaded a new beta, dated July 21 with all the improvements from m0rgg's branch plus a few of my own. You can find it in the Downloads section or the VR updates thread.

BTW, this is what the SteamVR performance looks like on my laptop:

https://www.youtube.com/watch?v=tfPkDmq ... e=youtu.be

I'm just waiting for people to confirm that this pre-release is OK to issue the formal release 1.1.4.

isometricbacon
Recruit
Posts: 4
Joined: Sun Jul 12, 2020 9:56 am

Post by isometricbacon » Wed Jul 22, 2020 12:40 pm

I can confirm a great performance improvement with this latest July 21 release, running in SteamVR. The 6dof headtracking judder seems pretty much gone.

Just played a few campaign missions. Still get the frame drops with heavy geometry scenes, but a significant improvement with looking around the cockpit. I was even able to bump the SteamVR resolution back up to 100% with a dealable level of performance.

User avatar
Trevor
Ensign
Posts: 406
Joined: Thu Dec 04, 2014 7:11 pm

Post by Trevor » Wed Jul 22, 2020 12:58 pm

BUG! in 20200721 version

Code: Select all

yaw_multiplier = 1
pitch_multiplier = 1
or
yaw_multiplier = -1
pitch_multiplier = -1
Have no effect and my HMD is inverted (Leaning left - game goes right, lean back - game goes forward)

This was fine in previous versions

Also, performance seems worse than last version - but that might be a side effect of wrong movement making me feel like that

Trev

User avatar
blue_max
Lieutenant Commander
XWAU Member
Posts: 1290
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Wed Jul 22, 2020 4:27 pm

@isometricbacon: thanks for testing this pre-release.

@Trevor: Sorry about the trouble. I don't think we touched those parameters, but I'm going to take a look anyway. The package had a Hook_CockpitLook.dll file in it. Did you replace it? You should only have one of those files.

User avatar
Trevor
Ensign
Posts: 406
Joined: Thu Dec 04, 2014 7:11 pm

Post by Trevor » Wed Jul 22, 2020 6:40 pm

yes and yes
Trev

P.S. I just found the log and last run was

Code: Select all

Cockpit Hook Loaded
Using SteamVR for tracking
Yaw multiplier: -1.000
Pitch multiplier: -1.000
Yaw offset: 0.000
Pitch offset: 0.000
External tilt: -1820
Parameters loaded
InitSteamVR()
VR_Init --> g_pHMD: 0x78938f38, error: 0x0
VR runtime loaded
Ill test inverting the numbers again - but I have a headache

Code: Select all

Driver: oculus
Display: 20B06R03EVHM

eyeLeft:
1.000000, 0.000000, 0.000000, -0.031750
0.000000, 1.000000, 0.000000, 0.000000
0.000000, 0.000000, 1.000000, 0.000000

eyeLeftInv:
1.000000, -0.000000, 0.000000, 0.031750
-0.000000, 1.000000, -0.000000, 0.000000
0.000000, -0.000000, 1.000000, -0.000000
-0.000000, 0.000000, -0.000000, 1.000000

Left Eye inverse test:
1.000000, 0.000000, 0.000000, 0.000000
0.000000, 1.000000, 0.000000, 0.000000
0.000000, 0.000000, 1.000000, 0.000000
0.000000, 0.000000, 0.000000, 1.000000

eyeRight:
1.000000, 0.000000, 0.000000, 0.031750
0.000000, 1.000000, 0.000000, 0.000000
0.000000, 0.000000, 1.000000, 0.000000

eyeRightInv:
1.000000, -0.000000, 0.000000, -0.031750
-0.000000, 1.000000, -0.000000, 0.000000
0.000000, -0.000000, 1.000000, -0.000000
-0.000000, 0.000000, -0.000000, 1.000000

Right Eye inverse test:
1.000000, 0.000000, 0.000000, 0.000000
0.000000, 1.000000, 0.000000, 0.000000
0.000000, 0.000000, 1.000000, 0.000000
0.000000, 0.000000, 0.000000, 1.000000

projLeft:
0.929789, 0.000000, 0.015672, 0.000000
0.000000, 0.750974, 0.000000, 0.000000
0.000000, 0.000000, -1.000010, -0.001000
0.000000, 0.000000, -1.000000, 0.000000

projRight:
0.929789, 0.000000, -0.015672, 0.000000
0.000000, 0.750974, 0.000000, 0.000000
0.000000, 0.000000, -1.000010, -0.001000
0.000000, 0.000000, -1.000000, 0.000000

Raw data (Left eye):
Left: -1.058658, Right: 1.092368, Top: -1.331603, Bottom: 1.331603
Raw data (Right eye):
Left: -1.092368, Right: 1.058658, Top: -1.331603, Bottom: 1.331603
using normal 1 in config

Code: Select all

Driver: oculus
Display: 20B06R03EVHM

eyeLeft:
1.000000, 0.000000, 0.000000, -0.031750
0.000000, 1.000000, 0.000000, 0.000000
0.000000, 0.000000, 1.000000, 0.000000

eyeLeftInv:
1.000000, -0.000000, 0.000000, 0.031750
-0.000000, 1.000000, -0.000000, 0.000000
0.000000, -0.000000, 1.000000, -0.000000
-0.000000, 0.000000, -0.000000, 1.000000

Left Eye inverse test:
1.000000, 0.000000, 0.000000, 0.000000
0.000000, 1.000000, 0.000000, 0.000000
0.000000, 0.000000, 1.000000, 0.000000
0.000000, 0.000000, 0.000000, 1.000000

eyeRight:
1.000000, 0.000000, 0.000000, 0.031750
0.000000, 1.000000, 0.000000, 0.000000
0.000000, 0.000000, 1.000000, 0.000000

eyeRightInv:
1.000000, -0.000000, 0.000000, -0.031750
-0.000000, 1.000000, -0.000000, 0.000000
0.000000, -0.000000, 1.000000, -0.000000
-0.000000, 0.000000, -0.000000, 1.000000

Right Eye inverse test:
1.000000, 0.000000, 0.000000, 0.000000
0.000000, 1.000000, 0.000000, 0.000000
0.000000, 0.000000, 1.000000, 0.000000
0.000000, 0.000000, 0.000000, 1.000000

projLeft:
0.929789, 0.000000, 0.015672, 0.000000
0.000000, 0.750974, 0.000000, 0.000000
0.000000, 0.000000, -1.000010, -0.001000
0.000000, 0.000000, -1.000000, 0.000000

projRight:
0.929789, 0.000000, -0.015672, 0.000000
0.000000, 0.750974, 0.000000, 0.000000
0.000000, 0.000000, -1.000010, -0.001000
0.000000, 0.000000, -1.000000, 0.000000

Raw data (Left eye):
Left: -1.058658, Right: 1.092368, Top: -1.331603, Bottom: 1.331603
Raw data (Right eye):
Left: -1.092368, Right: 1.058658, Top: -1.331603, Bottom: 1.331603

Code: Select all

Cockpit Hook Loaded
Using SteamVR for tracking
Yaw multiplier: 1.000
Pitch multiplier: 1.000
Yaw offset: 0.000
Pitch offset: 0.000
External tilt: -1820
Parameters loaded
InitSteamVR()
VR_Init --> g_pHMD: 0x78938f38, error: 0x0
VR runtime loaded
I have of course just realised these values ( Yaw/Pitch) are rotations not translations... anyhow, they don't work either (inverting rotations)
My rotations are fine, but my translations are inversed

User avatar
blue_max
Lieutenant Commander
XWAU Member
Posts: 1290
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Wed Jul 22, 2020 9:16 pm

I didn't realize this earlier, for the positional tracking the setting you've got to modify is "positional_x/y/z_multiplier", not the "yaw/pitch_multiplier". I'm not sure why those are inverted, but I would expect them to be at 1.

Can you post your CockpitLook.cfg file, Trevor?

User avatar
Trevor
Ensign
Posts: 406
Joined: Thu Dec 04, 2014 7:11 pm

Post by Trevor » Thu Jul 23, 2020 12:05 am

I totally missed those values (I had commented them out since they weren't of use anymore) Doh

Anyway, Ill test again.
IT WORKS!
so, those values are needed again (Still have a headache so haven't checked distance)
Actually I pushed through the headache and I now need the multipliers again (to travel 1m ingame with 1m in real life)
Seems like whatever changes were made in Jul17 have been reverted and now the multipliers and stuff are needed again...


here is cockpitlook

Code: Select all

; tracker_type selects what tracker to use. Valid options are:
; FreePIE
; SteamVR
; TrackIR (also compatible with OpenTrack when the output is freetrack 2.0 enhanced + TrackIR)
; None (for people who just want to use the regular mouse look mode)
tracker_type = SteamVR

; Setting these values above 1 will amplify the motion. Setting them to negative
; values will invert the axes. If you set them to 0, the axis will be disabled.
; For VR, the multipliers for roll and positional tracking (x,y,z) are in 
; vrparams.cfg
yaw_multiplier = 1
pitch_multiplier = 1

; Offsets that can be added to the pitch and yaw
yaw_offset = 0
pitch_offset = 0

;these are not needed anymore (pre Jul17) - Actually they are needed again (post Jul17)
positional_x_multiplier = 1.666
positional_y_multiplier = 1.666
positional_z_multiplier = 1.666


;min_positional_track_x = -25
;max_positional_track_x =  25

;min_positional_track_y = -25
;max_positional_track_y =  25

;min_positional_track_z = -25
;max_positional_track_z =  25

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

; Enable this setting to move around the cockpit using the keyboard arrows, see cockpitlook.cfg
keyboard_lean = 1

; If sticky_lean is set to 0, then the cockpit will return to its home position
; when the arrow keys are released. If set to 1, the position will stick where
; you leave it. Press the dot key twice to reset your position.
sticky_lean = 1

; Set this to 1 to limit the amount of cockpit lean. Set it to 0 for free-roam.
limit_cockpit_lean = 0

; +/- Limits for the keyboard lean. If these aren't specified, they default to infinity.
cockpit_lean_x_limit = 0.30
cockpit_lean_y_limit = 0.15
cockpit_lean_z_limit = 0.50

; Set the following to 1 to invert the keyboard lean on the y axis
invert_cockpit_lean_y = 0

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
; Inertia
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

; Cockpit Inertia, set the following to 0 to disable this effect:
cockpit_inertia_enabled = 1

; This setting controls how fast the cockpit moves, don't set it to
; values higher than 0.5 or the cockpit will shake when turning sharply
cockpit_inertia = 0.35

; This setting limits how far behind the cockpit lags when turning.
; Don't set it to high values or the cockpit will shake.
cockpit_max_inertia = 0.2

cockpit_speed_inertia = 0.005

external_inertia_enabled = 1
external_inertia = 1.5
external_max_inertia = 0.03
external_tilt = -10.0
Trev

User avatar
blue_max
Lieutenant Commander
XWAU Member
Posts: 1290
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Thu Jul 23, 2020 5:51 am

Trevor wrote:
Thu Jul 23, 2020 12:05 am
Anyway, Ill test again.
IT WORKS!
so, those values are needed again (Still have a headache so haven't checked distance)
Hey Trevor. Thanks for testing this, and I'm really sorry that you got a headache. You absolutely didn't need to power through that, so I appreciate it.

I checked these positional parameters and, honestly, I'm not sure what happened, but I made your settings (1.666f) the default from now on. Please let me know if you'd like me to use other settings instead in the future. (The settings can be overriden by CockpitLook.cfg, so that shouldn't affect other users).

Thanks again, your help is much appreciated.

aaadmiral
Cadet 4th Class
Posts: 24
Joined: Fri Apr 17, 2020 8:54 pm

Post by aaadmiral » Thu Jul 23, 2020 7:23 am

hey I just gave the july 21st preview a whirl, I set VRPrams VR mode to SteamVR and copied over Trevor's CockpitLook.cfg
performance seems worse to me than last time I checked, with OTT performance graph I'll just be staring straight in the x-wing cockpit (proving grounds) and the FPS will just dip randomly.. 90 down to 80, back up to 90, down to 83, up to 90.. thats with ASW disabled. with ASW enabled it just goes up and down from 90 to 45. after awhile it seems to stabilize a bit but then I turn head and it happens again.

If i turn off the graph and just fly around a bit it's not awful, and I don't have those reticle glitches or have to press "." or "ctrl+alt+shift+right arrow/left arrow" or anything like that.

edit: I realized I had my SteamVR resolution back up at 100%, I reduced that down to 50% as I had in previous testing and it seems closer to performance I had before I guess, the 'performance headroom' when set to 50% is RIGHT on the edge, if i'm at 90fps the headroom is only 2-5% so when I look over at the Shuttle it dips immediately.

btw, is there option somewhere for me to adjust the HUD position? sorta weird having the shields indicator and radar out of view

User avatar
blue_max
Lieutenant Commander
XWAU Member
Posts: 1290
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Thu Jul 23, 2020 7:46 am

I think if your performance dips from 90fps to 80fps then you're in *great* shape. I can rarely hit 90fps and I usually hover between 45-60fps with dips to 30-20fps when the screen is very busy. If you want to check what's your maximum ceiling, you can run the game in regular (non-VR) mode and check your maximum FPS. Bear in mind that SteamVR will cap the performance at 90fps, though. FWIW, I'm now playing at 100% resolution which in my case is 960x1080 per eye and I set the in-game resolution to 1280x768 (or something close to that) because that makes the text readable.

The HUD is a problem in VR -- that was the main reason I created the Dynamic Cockpit feature. But if your craft is not DC-enabled or if you prefer the HUD, then you can press Ctrl+Z to zoom it out to get a reduced version of the HUD. The scale of this zoomed-out version is given by the following setting in VRParams.cfg:

3d_window_zoom_out_size = 0.400

If you'd rather have the HUD zoomed out as soon as the game starts, then set the following:

zoomed_out_on_startup = 1

The reticle is independent of the HUD and its scale is controlled by:

reticle_scale = 0.7

You can also change the scale of the reticle in real time by pressing Ctrl+Left/Right Arrows

User avatar
Trevor
Ensign
Posts: 406
Joined: Thu Dec 04, 2014 7:11 pm

Post by Trevor » Thu Jul 23, 2020 3:21 pm

blue_max wrote:
Thu Jul 23, 2020 5:51 am
Hey Trevor. Thanks for testing this, and I'm really sorry that you got a headache. You absolutely didn't need to power through that, so I appreciate it.

I checked these positional parameters and, honestly, I'm not sure what happened, but I made your settings (1.666f) the default from now on. Please let me know if you'd like me to use other settings instead in the future. (The settings can be overriden by CockpitLook.cfg, so that shouldn't affect other users).

Thanks again, your help is much appreciated.
Yeah not sure either, as I say, everything "Just worked Out of Box" on Jul 17.

Testing Jul22 and I reset my fov (deleted the file to allow Auto to work) and rendering is great on my DK2 - FOV is correct, Movement is correct (1m ingame needs 1m in real life) and image encompasses vision.

However, New Bug - Reticle wanders.
Ive tried every setting, fixed, floating, 0.5m, 65535m but it still wanders therefore cannot be used to aim.
SightWrong.png
I am still waiting on Cockpit Shadows ;), each new beta I look for it. :P

Trev

P.S.
Anyone with VR, can you post a screenshot using my test model and report:
How many numbers you see when staring at 0 (eg, i see ~45 which = 90 which is correct for horizontal FOV for DK2)
How many squares from the left you are if your right eye is on the edge of the small cube.
Take your headset off, and move it untill you see the edge of the big cube on your monitor, now move it to the other edge and you should have moved 1meter in real life.

the more people that do this (and with different setups) the better profiles we can make.
You do not have the required permissions to view the files attached to this post.

User avatar
blue_max
Lieutenant Commander
XWAU Member
Posts: 1290
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Thu Jul 23, 2020 5:08 pm

Trevor wrote:
Thu Jul 23, 2020 3:21 pm
However, New Bug - Reticle wanders.
Ive tried every setting, fixed, floating, 0.5m, 65535m but it still wanders therefore cannot be used to aim.
If I remember correctly, your OPT replaces a cockpit (the X-Wing's cockpit?) so it might put the game in a weird state. Does this problem also happen when playing with a regular cockpit?

I *think* the reticle can be fixed by increasing/decreasing the FOV (Ctrl+Alt+Shit + Left Arrow followed by Ctrl+Alt+Shit + Right Arrow)

PS: Cockpit shadows have been enabled for a while, I just haven't published how to enable them :P

User avatar
Trevor
Ensign
Posts: 406
Joined: Thu Dec 04, 2014 7:11 pm

Post by Trevor » Thu Jul 23, 2020 6:01 pm

blue_max wrote:
Thu Jul 23, 2020 5:08 pm
If I remember correctly, your OPT replaces a cockpit (the X-Wing's cockpit?) so it might put the game in a weird state. Does this problem also happen when playing with a regular cockpit?

I *think* the reticle can be fixed by increasing/decreasing the FOV (Ctrl+Alt+Shit + Left Arrow followed by Ctrl+Alt+Shit + Right Arrow)
Yeah, and yes it happens on other cockpits.
Heh, I do NOT call that a fix, reducing the FOV will result in either of 2 things - a "zoomed-in" feel like looking at the world through binoculars OR reducing my vision to a square in the middle.
Remember that with VR there is only 1 FOV and that is the FOV of the device, any deviation from that value will not be right in VR.
On a flat monitor it makes little difference and can be used to zoom-in on targets etc, but VR FOV is as important as Positional tracking, any errors result in distortion which could result in motion sickness.

PS: Cockpit shadows have been enabled for a while, I just haven't published how to enable them :P
Oh you tease... :P

Trev

User avatar
blue_max
Lieutenant Commander
XWAU Member
Posts: 1290
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Thu Jul 23, 2020 6:23 pm

Trevor wrote:
Thu Jul 23, 2020 6:01 pm
Yeah, and yes it happens on other cockpits.
Do you have a repro? I've been testing several cockpits and I haven't this this happen in a while.
Heh, I do NOT call that a fix, reducing the FOV will result in either of 2 things - a "zoomed-in" feel like looking at the world through binoculars OR reducing my vision to a square in the middle.
Well, yeah you're right that there's only one correct FOV in VR. However, changing the VR FOV should not change the apparent size of anything or cause any distortion. It should only change the actual field of view: it will crop the image or let you see more around it, but it should not change the size of the 3D objects at all. I should publish a video showing the effect.

The reason I call this a "fix" is that changing the FOV triggers code that recomputes the position of the reticle. As long as the reticle is visible on the screen when you press the key combination to change the FOV, it should get captured and processed. The same code is triggered (I believe) if you press the dot key twice, so that should also help?

User avatar
blue_max
Lieutenant Commander
XWAU Member
Posts: 1290
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Fri Jul 24, 2020 6:37 am

Trevor wrote:
Thu Jul 23, 2020 6:01 pm
PS: Cockpit shadows have been enabled for a while, I just haven't published how to enable them :P
Oh you tease... :P
See this thread my friend:

https://www.xwaupgrade.com/phpBB3/viewt ... =9&t=12650

:)

aaadmiral
Cadet 4th Class
Posts: 24
Joined: Fri Apr 17, 2020 8:54 pm

Post by aaadmiral » Sat Jul 25, 2020 6:52 am

Trevor wrote:
Thu Jul 23, 2020 3:21 pm
Anyone with VR, can you post a screenshot using my test model and report:
How many numbers you see when staring at 0 (eg, i see ~45 which = 90 which is correct for horizontal FOV for DK2)
How many squares from the left you are if your right eye is on the edge of the small cube.
Take your headset off, and move it untill you see the edge of the big cube on your monitor, now move it to the other edge and you should have moved 1meter in real life.

the more people that do this (and with different setups) the better profiles we can make.
how do I use do this exactly? I downloaded this xwingcockpit.opt but not sure what to do with it

User avatar
Trevor
Ensign
Posts: 406
Joined: Thu Dec 04, 2014 7:11 pm

Post by Trevor » Sat Jul 25, 2020 10:50 am

Rename your current cockpit in the flightmodels folder to xwingcockpit.bak then paste this one here then load an empty skirmish or proving grounds with x-wing
Trev

aaadmiral
Cadet 4th Class
Posts: 24
Joined: Fri Apr 17, 2020 8:54 pm

Post by aaadmiral » Sun Jul 26, 2020 5:22 am

OK, for some reason for me I start with the cube in front of me and I can't see zero unless I look around it.. is that normal? even then I can't actually see any of the numbers when looking at zero.

I'm on oculus cv1 btw. going to try and use OTT to mirror my view to monitor so I can take proper screen shots, right now it just crashes on me and doesn't save the clipboard screenshot

edit: btw, that cube in front of me is shaking/jittering like crazy.. maybe I can screen record to show that.. but the purple HUD remains totally stationary so not sure if that's a tracking issue or not. I have 3 sensors but they're not setup totally ideally for seated play

User avatar
keiranhalcyon7
Lieutenant JG
Posts: 577
Joined: Tue Jan 02, 2018 6:41 am

Post by keiranhalcyon7 » Tue Jul 28, 2020 7:37 am

Trevor wrote:
Thu Jul 23, 2020 6:01 pm
Heh, I do NOT call that a fix
Uhh, I think the suggestion was to alter the FOV, and then immediately undo it with the reverse operation, just to trigger the recalc code. Which I'd call more of a workaround than a fix, but it shouldn't cause motion sickness, I think.

User avatar
Trevor
Ensign
Posts: 406
Joined: Thu Dec 04, 2014 7:11 pm

Post by Trevor » Tue Jul 28, 2020 1:10 pm

keiranhalcyon7 wrote:
Tue Jul 28, 2020 7:37 am
Trevor wrote:
Thu Jul 23, 2020 6:01 pm
Heh, I do NOT call that a fix
Uhh, I think the suggestion was to alter the FOV, and then immediately undo it with the reverse operation, just to trigger the recalc code. Which I'd call more of a workaround than a fix, but it shouldn't cause motion sickness, I think.
oh, I assumed it was to reduce the FOV to fix the reticle not to just cycle the code

Trev

Buck3131
Recruit
Posts: 1
Joined: Thu Jul 30, 2020 6:57 pm

Post by Buck3131 » Thu Jul 30, 2020 7:20 pm

Ok Just got this all instaleed and have this issue
Index Headset.
When i get in a ship in the hangar i look around and the cockpit moves with my view. If i move the mouse, it moves the game world.
I'm probably missing something very simple but would appreciate some help.
Thanks
Buck

Post Reply