Troubleshooting SteamVR

Here you can find help for how to best run and setup your XWA VR experience.
Post Reply

Troubleshooting SteamVR

User avatar
blue_max
Lieutenant Commander
XWAU Member
Posts: 1435
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Fri Jul 31, 2020 5:27 pm

GENERAL:

* Text is unreadable: Set the in-game resolution to 1024x768 or 1280x1024. You can also enable "Text2DRendererEnabled = 1" in DDraw.cfg, but that'll have a performance penalty.

* The game will crash/won't load SteamVR: Check that you have exactly one ddraw.dll and one Hook_CockpitLook.dll in your XWA install directory. Antivirus software sometimes may delete DLL files because we're intentionally modifying XWA to extend its functionality. Check that you have these files.

* The reticle is off, I can't aim! Look straight and press the dot/period key twice, or press Ctrl+Alt+Shift+Left Arrow followed by Ctrl+Alt+Shift+Right Arrow. The VR mod will try to capture the reticle to prevent distortion in VR, but sometimes the algorithm fails. This procedure re-triggers the reticle capture algorithm. If you have a consistent repro for this issue, feel free to post it and I'll take a look since this is something I really want to fix.

* How do I re-center the screen: Look straight ahead and press the dot/period key twice.

* No concourse/black screen when the game loads: Try re-centering the screen by pressing the dot/period key twice or recalibrate your HMD. Also check that tracking is enabled (see below).

* The game fades to the default screen when loading a mission. Mission loading screens will stop refreshing the screen, so SteamVR may fade to the default VR screen. To prevent this, open SteamVR -> Settings -> Developer. Enable "Do not fade to grid when app hangs"

* I don't want to see the HUD anymore in DC-enabled cockpits. When you install the DC cockpits, there's an option to keep the full HUD, only the text boxes, or get rid of the HUD completely. Just run the installer again and select "I don't need the HUD anymore".

* The text in the Y-Wing CMD is unreadable: Open "DynamicCockpit\YWingCockpit.dc" and find the line that starts with "uv_coords = TARGETING_COMPUTER_SRC" and replace it with:

Code: Select all

uv_coords    = TARGETING_COMPUTER_SRC, 0,128, 256,0; 0x0
TRACKING ISSUES:

* No tracking: Check that you have "VR_Mode = SteamVR" in VRParams.cfg and "tracker_type = SteamVR" in CockpitLook.cfg. Check that you only have one Hook_CockpitLook.dll in your XWA directory. If you have renamed the hook, but kept the DLL extension that'll cause trouble (for instance if you have Hook_CockpitLook-1.dll and Hook_CockpitLook.dll).

* I did the above and there's still no tracking in the hangar: Fixed in release 1.1.4.

* Positional tracking works, but the scale isn't right: try adjusting the "positional_x/y/z_multiplier" settings in CockpitLook.cfg.

* How to disable cockpit inertia: set "cockpit_inertia_enabled = 0" in CockpitLook.cfg.

JITTERING:

* If your framerate is low, that may affect positional tracking and cause jittering. Try lowering down the resolution in SteamVR or reduce the number of effects. I tend to play with 50-70% resolution.

* Some users have reported that disabling the Active Cockpit also helps alleviate issues with jittering. Open Active_Cockpit.cfg and set "active_cockpit_enabled = 0" to disable this feature.

* Other users have reported that setting the in-game resolution to 640x480 helps fix the jittering. Personally, I tend to play at an in-game resolution of 1280x1024 or 1024x768; but I set the desktop resolution to the SteamVR per-eye resolution.

MIRROR WINDOW:

* The mirror window looks squashed: Try setting "steamvr_mirror_aspect_ratio" to values slightly above or below 1.0 in VRParams.cfg and press Ctrl+Alt+L to reapply the setting.

* The mirror window is too big/too small: You can adjust the scale of the mirror window with the "steamvr_mirror_window_scale" setting in VRParams.cfg.

PERFORMANCE:

* All the tips from this thread also apply in VR:

https://www.xwaupgrade.com/phpBB3/viewt ... =9&t=12490

Personally, I tend to play with "ssao_type = Deferred" since that provides the best performance with most of the effects on.

* The biggest performance impact comes from the SteamVR resolution. I tend to set it between 50-100%. For me 100% is 960x1080.

* Be sure to set "ProcessAffinityCore = 0" in DDraw.cfg -- that'll give you about a 15% improvement in performance.

* The active cockpit does take an impact on performance depending on the cockpit. Try disabling that if you're not using that feature. This has also helped fix some jittering issues some users have reported. Open Active_Cockpit.cfg and set "active_cockpit_enabled = 0" to disable this feature.

* Reduce the FOV. The greater FOV needed for VR also means that more geometry is rendered. I try to estimate the FOV from the data provided by SteamVR, but chances are you can lower the FOV a little bit. Open Focal_Length.cfg and set "VR_FOV" to a lower value (in degrees). You can also change the FOV in real-time by pressing Ctrl+Alt+Shift + Left/Right Arrows. If the FOV becomes too low you'll start seeing black bars near the edges.

* Set the xwingalliance.exe process to run with Real Time priority. If none of the above helps get a reasonable performance, you can also bring up the Task Manager and change the priority of xwingalliance.exe to be "Real Time". This will cause other processes to run more slowly, so just be mindful of that.

* Sometimes the game may slow down when you hit another ship with lasers. You can disable the "Hit Effects" in the XWA menu to avoid this problem.

* If you have an nVidia card, set "Low Latency Mode -ON". See additional posts below by nuttyapprentice.
Last edited by blue_max on Fri Aug 28, 2020 9:47 pm, edited 10 times in total.

User avatar
ual002
Lieutenant
XWAU Member
Posts: 825
Joined: Wed Sep 24, 2008 2:23 am

Post by ual002 » Fri Jul 31, 2020 7:29 pm

Recommend ability to turn of Hangar tracking with option because without VR it seems to keep mouselook from functioning.
Image Image Image Image Image

User avatar
blue_max
Lieutenant Commander
XWAU Member
Posts: 1435
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Fri Aug 07, 2020 7:11 am

Mouse look in the hangar has been fixed when TrackIR is enabled in the release from Aug 6. Thanks for reporting the issue.

nuttyapprentice
Recruit
Posts: 9
Joined: Sun Aug 09, 2020 2:13 pm

Post by nuttyapprentice » Wed Aug 19, 2020 8:25 pm

Not sure if its only a fix with SteamVR, but i had a problem with jittery head movement, even when not much was going on and the mirrored view was running buttery smooth. I adjusted most of the settings below one by one, the biggest changes were with the steamvr motion smoothing and vrparams reprojection settings and the low latency nvidia setting. I still have slow down when theres a lt of large ships on the screen but otherwise I managed to make everything really smooth doing the following:

Nvidia Control Panel:
Low Latency Mode -ON (limits number of frames the CPU can prepare before sending to the GPU, this had a huge effect on the jitters for me)
Max Frame Rate -90fps
Texture Filtering -Quality -Perfomance
Vsync -Off

SteamVR:
Per app settings:
Resolution is personal pref, im on Vive-Pro and got it working fine on 111%
Motion Smoothing - Off (I enabled it in VR params below)

XWA Config:
VRParams.cfg: SteamVR_Interleaved_Reprojection = 1
Bloom.cfg: Bloom_levels = 5
Active_Cockpit.cfg: Active_Cockpit_enabled = 0
DDraw.cfg: EnableMultisamplingAntialiasing = 0
EnableFXAA = 0
EnableAnisotropicFiltering = 1
SSAO.cfg: ssao_type = Deferred
samples = 6
max_dist = 120
speed_shader_max_particles = 180

Task Manager:
Set priority of XWA to high (details, right click) (have to do this each time you start)
You do not have the required permissions to view the files attached to this post.

nuttyapprentice
Recruit
Posts: 9
Joined: Sun Aug 09, 2020 2:13 pm

Post by nuttyapprentice » Wed Aug 19, 2020 8:29 pm

taskmanager:
You do not have the required permissions to view the files attached to this post.

User avatar
blue_max
Lieutenant Commander
XWAU Member
Posts: 1435
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Wed Aug 19, 2020 10:01 pm

Thanks for sharing your settings, nuttyapprentice! One note: if you set "Deferred" as the shading type, then I believe the "samples" and "max_dist" settings have no effect.

I didn't know about the Low-Latency mode, now I'm definitely going to try that.

nuttyapprentice
Recruit
Posts: 9
Joined: Sun Aug 09, 2020 2:13 pm

Post by nuttyapprentice » Wed Aug 19, 2020 11:08 pm

good to know, I think I set the samples and dist when i had SSDO set on, then went to deferred afterwards. One seting i forgot to mention was turning off the hit effect from the in game hardware options, stops the stuttering when you hit someone with a laser.

Post Reply