Page 1 of 1

Game doesn't display in headset only on screen

Posted: Thu Oct 29, 2020 1:17 am
by nitroplonker

I am unable to get the mod working properly, whenever I launch SteamVR then the game, within the headset I just get the loading window saying "X-wing alliance up next" while the game is running on my pc monitor. The tracking seems to be working on the monitor it's just not showing in the hmd.

This is my log file :

Cockpit Hook Loaded
Using SteamVR for tracking
Yaw multiplier: 1.000
Pitch multiplier: 1.000
Yaw offset: 0.000
Pitch offset: 0.000
External tilt: -1820
Parameters loaded
VR_Init --> g_pHMD: 0x60321048, error: 0x0
VR runtime loaded

Would really appreciate any pointers on how I might fix it.

Re: Game doesn't display in headset only on screen

Posted: Sat Oct 31, 2020 5:09 am
by blue_max
Check that your VRParams.cfg has "VR_Mode = SteamVR".

Make sure you're looking forward and press the period key twice to reset the view.

Does SteamVR show any error messages?

Do you have multiple video cards installed in your system? If so, is the right video card selected in XWA? Is your HMD connected to the right video card?

Are you running Windows 10? This mod has some issues when trying to run in Windows 7.

Re: Game doesn't display in headset only on screen

Posted: Sun Nov 15, 2020 1:03 am
by nitroplonker
Thanks for your reply, I have fixed the issue due to what you said.

I am on a Razer Blade 2017 laptop which does indeed have 2 graphics cards, an onboard one and a 1060. After forcing the game to use the 1060 it seems to have fixed the problem.

The performance is too jerky to play, though it is running in vr. Think my graphics card is starting to show it's age and not up to running this smoothly. Will have to wait until i upgrade.

Thanks again

Re: Game doesn't display in headset only on screen

Posted: Mon Nov 16, 2020 6:58 am
by blue_max
I've got a Surface Book 2, it has a 1060 nVidia and it's also from around 2017 or so. VR works OK (not great, but also not jerky -- it's very playable). I do have to set the resolution down to 1920x1080 to play in VR, though. See the posts in these threads for tips on how to improve your performance:



Also, looks like a few people have reported that the Active Cockpit is a consistent source of jerkiness. Open Active_Cockpit.cfg and set "active_cockpit_enabled = 0" to disable it -- that might help.