New effects and installers

All the XWAU recent release news from the project can be found here
Post Reply

Re: New effects and installers

User avatar
Driftwood

Admiral (Moderator)
Posts: 2071
Joined: Wed Oct 22, 2003 11:01 pm
Contact:

Post by Driftwood » Thu Jun 18, 2020 10:06 pm

Yes, do not install individual ships released prior to the main pack and DC installers, unless marked new and/or dated after those installers as you could create bugs for yourself by overwriting newer files as we seem to be seeing in spite of posted directions.

Bob_Sinclar
Cadet 4th Class
Posts: 18
Joined: Sun May 03, 2020 9:26 pm

Post by Bob_Sinclar » Fri Jun 19, 2020 10:07 pm

Hi Driftwood,

In my case I installed everything properly (all existing installers) and only then I installed only "NEW" crafts such as XWing v6.0.
Based on my understanding each time I install a new craft I have to reinstall the dynamic cockpit installer afterwards to make sure I keep the cockpit I want.
I hope the nr of new crafts will be limited otherwise the dynamic cockpit installer will be used many times...

I still do not understand why XWing 6.0 has be designed with a different cockpit hat the one used in the dynamic cockpit. strange...

User avatar
Vince T

Fleet Admiral (Administrator)
Posts: 12842
Joined: Fri Apr 27, 2001 11:01 pm
Contact:

Post by Vince T » Fri Jun 19, 2020 10:22 pm

You don't have to re-install the dynamic cockpit after every craft you install. If you intend to install all the rebel and imperial fighters manually, it's enough to install the cockpits once at the very end.

We are working on sorting this out and there will a proper post detailing the way forward in the near future. All we ask is a little patience.
Your ship, Captain. I need a drink. - Vince Trageton

My Steam Workshop

User avatar
Driftwood

Admiral (Moderator)
Posts: 2071
Joined: Wed Oct 22, 2003 11:01 pm
Contact:

Post by Driftwood » Fri Jun 19, 2020 11:26 pm

Bob_Sinclar wrote:
Fri Jun 19, 2020 10:07 pm
Hi Driftwood,
I still do not understand why XWing 6.0 has be designed with a different cockpit hat the one used in the dynamic cockpit. strange...
Me either, but:
Do not install individual ships released prior to the main pack and DC installers
Because
General_Trageton wrote:
Fri Jun 19, 2020 10:22 pm
We are working on sorting this out and there will a proper post detailing the way forward in the near future. All we ask is a little patience.
And if you just hang tight we can get you going in the right direction. :^^:

FatnSlo
Recruit
Posts: 3
Joined: Sun Jun 21, 2020 4:32 pm

Post by FatnSlo » Mon Jun 22, 2020 6:21 pm

If I install EffectsByBlueMax_v1.1.3.2 then the animations of my ship taking off and landing are no longer smooth. The animations will often stutter or freeze altogether although the game does not freeze nor is there any drop in FPS. If I try a separate install of XWA that only has the XWAU Craft Pack 1.6 installed, the ships taking off and landing animations are smooth. I have tried changing various options in the DDraw file, but nothing seems to change this problem. Any idea why this is happening?

User avatar
blue_max
Lieutenant Commander
XWAU Member
Posts: 1290
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Mon Jun 22, 2020 8:21 pm

FatnSlo wrote:
Mon Jun 22, 2020 6:21 pm
If I install EffectsByBlueMax_v1.1.3.2 then the animations of my ship taking off and landing are no longer smooth. The animations will often stutter or freeze altogether although the game does not freeze nor is there any drop in FPS.
Try setting EnableVSyncInHangar = 1 in DDraw.cfg

FatnSlo
Recruit
Posts: 3
Joined: Sun Jun 21, 2020 4:32 pm

Post by FatnSlo » Tue Jun 23, 2020 6:10 pm

blue_max wrote:
Mon Jun 22, 2020 8:21 pm
FatnSlo wrote:
Mon Jun 22, 2020 6:21 pm
If I install EffectsByBlueMax_v1.1.3.2 then the animations of my ship taking off and landing are no longer smooth. The animations will often stutter or freeze altogether although the game does not freeze nor is there any drop in FPS.
Try setting EnableVSyncInHangar = 1 in DDraw.cfg
So I found what was causing the hangar problem for me. I had my monitor set to run at 144Hz in Nvidia control panel. I changed it to run at 60Hz instead and now I no longer have any problems. But I do have to run the EnableVSyncInHangar = 1 still as the ship may freeze just as it is exiting the hangar without it.
Last edited by FatnSlo on Tue Jun 23, 2020 8:32 pm, edited 1 time in total.

User avatar
blue_max
Lieutenant Commander
XWAU Member
Posts: 1290
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Tue Jun 23, 2020 7:19 pm

FatnSlo wrote:
Tue Jun 23, 2020 6:10 pm
So I found what was causing the hangar problem for me. I had my monitor set to run at 144Hz in Nvidia control panel I changed it to run at 60Hz instead and now I no longer have any problems. But I do have to run the EnableVSyncInHangar = 1 still as the ship may freeze just as it is exiting the hangar without it.
Didn't know this was possible. Thanks for sharing!

axeil55
Recruit
Posts: 8
Joined: Mon Aug 10, 2020 5:30 am

Post by axeil55 » Wed Aug 12, 2020 1:13 pm

I was also getting the hanger bug and manually set the max refresh rate for XwingAlliance.exe to 60 fps in MSI Afterburner which fixed the problem without requiring me to set my monitor refresh rate down to 60. Shame though as you lose the ability to go >60 fps in-flight.

User avatar
blue_max
Lieutenant Commander
XWAU Member
Posts: 1290
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Wed Aug 12, 2020 6:24 pm

axeil55 wrote:
Wed Aug 12, 2020 1:13 pm
I was also getting the hanger bug and manually set the max refresh rate for XwingAlliance.exe to 60 fps in MSI Afterburner which fixed the problem without requiring me to set my monitor refresh rate down to 60. Shame though as you lose the ability to go >60 fps in-flight.
There is no need to cap your game at 60fps. I can get 90+fps when running at a resolution of 1920x1080 on my laptop without issues. Just set your monitor refresh rate to 60Hz

axeil55
Recruit
Posts: 8
Joined: Mon Aug 10, 2020 5:30 am

Post by axeil55 » Wed Aug 12, 2020 11:50 pm

blue_max wrote:
Wed Aug 12, 2020 6:24 pm
axeil55 wrote:
Wed Aug 12, 2020 1:13 pm
I was also getting the hanger bug and manually set the max refresh rate for XwingAlliance.exe to 60 fps in MSI Afterburner which fixed the problem without requiring me to set my monitor refresh rate down to 60. Shame though as you lose the ability to go >60 fps in-flight.
There is no need to cap your game at 60fps. I can get 90+fps when running at a resolution of 1920x1080 on my laptop without issues. Just set your monitor refresh rate to 60Hz
I would rather cap the game at 60 than have to manually change my monitor refresh rate to 60 every time I play the game. Thanks though!

User avatar
Ace Antilles

Admiral (Moderator)
Posts: 4578
Joined: Sat Jan 22, 2000 12:01 am
Contact:

Post by Ace Antilles » Fri Aug 14, 2020 7:42 pm

Effects V.1.1.4. From Blue Max

Image

The latest full stable release from Blue Max is available to download NOW!
With more of his Virtual Reality improvements and wondrous effects.
Some of the new features in this release are:

* Fully-metric and distortion-free SteamVR mode.
* SteamVR Performance Improvements.
* Head Tracking in the Hangar and Concourse.
* Cockpit Shadows/Shadow Mapping.
* Reticle placement in VR.
* SteamVR Mirror Window.
* Wireframe targeting computer mode.
* POV Offsets.



Wireframe targeting computer mode
Many of you may have already tried this Beta feature but this and many more improvements will be available in v1.1.4.
Now you can get an almost retro gaming look to targeting your enemies. Also the individual components will flash to highlight them.

Wireframe-and-subcomponent-2.gif
You do not have the required permissions to view the files attached to this post.
Chief XWAU Team annoying nitpicker.
Ace Antilles - The X-Wing Outpost
Image

Ronin65
Cadet 3rd Class
Posts: 36
Joined: Thu Jul 02, 2020 1:00 pm

Post by Ronin65 » Fri Aug 14, 2020 8:38 pm

Just a heads up guys, but the Effects V.1.1.4 does not include all the latest Hooks that JeremyaFr implemented recently, not to worry, your game will still work ok, but I would have thought that something this important would be up to date in all it's features.

User avatar
DarHan
Cadet 1st Class
Rebel Alliance
Posts: 232
Joined: Mon Dec 05, 2005 12:01 am
Contact:

Post by DarHan » Fri Aug 14, 2020 9:49 pm

IIRC, the effects pack has never included hook updates except for cockpit-related hooks.
“Red Four, nothing’s gone wrong yet.”
— Hobbie Klivian

Ronin65
Cadet 3rd Class
Posts: 36
Joined: Thu Jul 02, 2020 1:00 pm

Post by Ronin65 » Fri Aug 14, 2020 10:43 pm

Hasn't it really! Sorry but you recall incorrectly about this. Yes it does include other hooks necessary for the effects to work, but it also includes all the hooks, Try use a little program called 7-zip to extract the exe

Chri360936
Cadet 3rd Class
Posts: 28
Joined: Thu Jun 20, 2019 3:28 am

Post by Chri360936 » Fri Aug 14, 2020 11:49 pm

I just installed 1.1.4 and have a question about field of view. I use trackIR with the game for head tracking. My field of view is huge now. It seems I am sitting a mile away from the front of the cockpit. In the old version I could adjust this with Shift/Ctrl/Alt + Arrow keys. In the latest version this does not work. How do I adjust this now? Thanks.

User avatar
blue_max
Lieutenant Commander
XWAU Member
Posts: 1290
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Sat Aug 15, 2020 2:56 am

Chri360936 wrote:
Fri Aug 14, 2020 11:49 pm
My field of view is huge now. It seems I am sitting a mile away from the front of the cockpit. In the old version I could adjust this with Shift/Ctrl/Alt + Arrow keys. In the latest version this does not work. How do I adjust this now? Thanks.
Those keys still work (I just double-checked). I assume you didn't run xwahacker to modify any settings, so try erasing your FocalLength.cfg file and run the game again. If that doesn't work, you can put the following line in that file:

real_FOV = 52

(Yes, the real default FOV in XWA is around 50 degrees)

If that still doesn't work, then I'd like to see your SSAO.cfg, FocalLength.cfg, DDraw.cfg and POVOffsets.cfg files (you can PM them to me).

Chri360936
Cadet 3rd Class
Posts: 28
Joined: Thu Jun 20, 2019 3:28 am

Post by Chri360936 » Sat Aug 15, 2020 3:01 am

I feel like a moron, but I can't find a focallength.cfg file. The others are all there.

Chri360936
Cadet 3rd Class
Posts: 28
Joined: Thu Jun 20, 2019 3:28 am

Post by Chri360936 » Sat Aug 15, 2020 3:07 am

Here is an image to give you an idea of what I see.
Cockpit View.jpg
You do not have the required permissions to view the files attached to this post.

User avatar
blue_max
Lieutenant Commander
XWAU Member
Posts: 1290
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Sat Aug 15, 2020 3:09 am

Chri360936 wrote:
Sat Aug 15, 2020 3:01 am
I feel like a moron, but I can't find a focallength.cfg file. The others are all there.
This file is only created if you press Ctrl+Alt+Shift + Left/Right Arrow. If it isn't there, that means that your xwingalliance.exe is using a large FOV by default now. Go ahead and create a FocalLength.cfg file in your XWA directory and put 50 degrees in there like I posted above.

Chri360936
Cadet 3rd Class
Posts: 28
Joined: Thu Jun 20, 2019 3:28 am

Post by Chri360936 » Sat Aug 15, 2020 3:21 am

I created the file and put that line in and it had no effect. When I hit the key stroke combo the cockpit flickers then goes right back to the large FOV. This only started happening with the new effects version. Worked great on the last version. I hope that helps narrow it down.

Chri360936
Cadet 3rd Class
Posts: 28
Joined: Thu Jun 20, 2019 3:28 am

Post by Chri360936 » Sat Aug 15, 2020 3:26 am

Cockpit View 2.jpg
Somehow I've made it worse by deleting the recently created focallength.cfg and then restoring the file to the directory.
You do not have the required permissions to view the files attached to this post.

Chri360936
Cadet 3rd Class
Posts: 28
Joined: Thu Jun 20, 2019 3:28 am

Post by Chri360936 » Sat Aug 15, 2020 3:49 am

So I think I found what the problem may have been. In my DynamicCockpits folder, the XwingCockpit.DC file has the following line:

;FIELD OF VIEW
xwahacker_fov = 89
xwahacker_large_fov = 95.5

Originally the 89 was 165.something. It was huge. I changed it to 89 and it is much better. I still can't change the FOV in game though.

User avatar
blue_max
Lieutenant Commander
XWAU Member
Posts: 1290
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Sat Aug 15, 2020 4:51 am

Chri360936 wrote:
Sat Aug 15, 2020 3:49 am
So I think I found what the problem may have been. In my DynamicCockpits folder, the XwingCockpit.DC file has the following line:

;FIELD OF VIEW
xwahacker_fov = 89
xwahacker_large_fov = 95.5

Originally the 89 was 165.something. It was huge. I changed it to 89 and it is much better. I still can't change the FOV in game though.
Alright, I think I know what's going on now. There's 3 FOV settings now: the global FOV, which is set through FocalLength.cfg, and 2 per-craft FOVs which are set for regular play (xwahacker_fov) and wide-res screens (xwahacker_large_fov). These FOVs were introduced because some people like to play on regular screens and some people like large screens and yet some people do 3-monitor super-wide screens. To cycle between the different FOV settings, press Ctrl+F. I believe the shortcut keys should work on all FOV settings, but I'll check that.

Anyway, the simplest fix would be to remove the xwahacker_fov and xwahacker_large_fov lines from the DC files, and also remove FocalLength.cfg. That should restore the default FOV (and the shortcut keys).

Chri360936
Cadet 3rd Class
Posts: 28
Joined: Thu Jun 20, 2019 3:28 am

Post by Chri360936 » Sat Aug 15, 2020 12:08 pm

I'll give that a shot. Thanks for taking the time to look into this. The work you and the team are doing on this is incredible. Thank you all so much.

Post Reply